Joomla: Extensions Error



I’m trying to download an extension that allows comments on the articles.

I had one previously downloaded called CComment. It was the free version. I was going to try it and if I liked it, I would buy the full version. The free version didn’t work at all and there is no support for it. So I uninstalled the extension.

I tried to install another extension called JU Comment and got an error message:
Invalid URL
Unable to find install package.

I did some research online and found that someone else had the same problem (they were using a different host provider) and they had to turn on the FTP. So I went into my configuration and tried to turn my on too. That didn’t work out as well as I would have hoped as I didn’t know what the FTP Root was but I had all the other information.

With some more research, I found that for DreamHost users, the FTP option should be turned off. So I turned it back off.

Now I’m seeing two errors when I try install extensions (not just JU Comment, all extensions):
Error connecting to the server: 403
Invalid URL
Unable to find install package.



You haven’t really given us enough details to help.

SFTP should work just as well for you. I agree ftp should be turned off, it’s very old and very insecure.

Let us know specifically what you are doing and where the problem starts for you. For example you might provide a link to the installation instructions you are trying to follow, and let us know where you are running into to issues. Example: “I can’t get past step 5, but in Step2 the directory it said to use wasn’t there so I created it”… etc etc.


There are no installation instructions.

I’ll give a more in-depth description of what I did:

Last week, I logged into the backend of Joomla and went to the extensions tab which took me directly to the Install from the Web view (which is where I always go to download an extension). I used the categories in the left panel to find a comment extension (Contacts & Feedback > Article comments). I clicked on CComment Core (after doing a little research of the extension), and on the confirmation window, I clicked Install and after a moment got the green success message box.

I didn’t mess with any setting, I just went to my site to see what the new comment feature looked like and I loved it so I tried to test it. When I clicked the “Write Comment” button, it showed the comment platform but also a warning at the bottom of the screen:
Warning: array_intersect(): Argument #2 is not an array in /home/jeniouis/ on line 277

Having no idea what to think of that, I first tried to write a comment and post it anyway but as expected, it didn’t work. CComment doesn’t provide support for their free version of the product, so after a brief moment of searching online for answers, I simply decided to uninstall the extension.

I returned to the backend of Joomla and went to global configuration where there was an uninstall button for the CComment extension. I clicked it and nothing happened. Then I went back to the extensions tab, this time clicking the manage button. When all the extensions on the site popped up, I searched for CComment and uninstalled the four results (CComment-a component, Content - CComment, K2 Plugin - CComment, Search - CComment) and uninstalled each, manually.

I tried to download another comment extension via the extensions tab but I got the error message. And this is where my original post comes in.

Please note:
I was able to reinstall the CComment extension and got it to work this time. I suspect the issue was that it comes with a default gravatar and I don’t have gravatar set-up for my users.
However, I’m still concerned this error will prevent me from installing extensions in the future. I haven’t tried to install anything else since.