Joomla and Open SEF problems with Dreamhost

apps

#1

Hi,

I signed up with DH a couple of days back. Now, I know that I can’t run Apache here. But Open SEF, a search engine friendly component for Joomla needs Apache to run.

How do I go about installing Open SEF at DreamHost? I would be really grateful if somebody could help me find a solution.

Thanks a lot in advance.

Hey, do you know you can get one year hosting with free domain name for 22.4$ only?
Yeah, just use MORE97 as a promo code while signing up with Dreamhost.


#2

Dreamhost is using the Apache web server, including mod_rewrite. If those are the only dependencies, this plugin should run fine.


If you want useful replies, ask smart questions.


#3

I installed Joomla! 1.0.10 and OpenSEF 2.0.0 RC5 on my site, jdlh.com, with no problems related to Dreamhost or the web server. It worked for me.

(OpenSEF fails to work with another component I need, Joom!Fish, so I removed it, but that’s not germane here.)

Jim DeLaHunt, jdlh.com - consultant in world-ready technology and business development


#4

Try checking the Joomla forums, they have a lot of good help with SEO. Keep in mind that you’ll have problems if you’re trying to run two Joomla sites with SEO under the same user account. I simply created a second webspace to remedy this.

http://help.joomla.org/content/view/796/226/

BC Tech
Team Shocker


#5

hi there,
im traying to install joomSeo on my site.
I think im having trouble with the .htaccess.txt.
If i upload and .htaccess with this single line
Redirect /google.html http://www.google.com
i have a 404 error.
Any ideas? i do have more than one site under my dreamhost user account.
Any help or directions would be appreciated.

regards, goliatone

Glad to help you out with any AS or flash related doubts.


#6

The system property/php inspector in Joomla seems to show that mod_rewrite is not installed, the Joomla doc you provided the link to suggests one must request their host to enable/install mod_rewrite is it indeed missing, can I get dreamhost to add it?


#7

I would appreciate any tips from those who have “been there”

When I enable Joomla’s built in SEO friendly url option, I then get the error:

FATAL ERROR: Unable to read file (/home/myAccount/myDomain.com/administrator/components/com_sef/config.sef.php)

Don’t see the config.sef.php file in that ftp directory. scouring the web turned up some reports of this same message with no concise corrections.

I have .htaccess renamed, with one of the options decommented.

Any vague leads would get me a step in the right direction.


#8

mod_rewrite is installed on DreamHost, and I use the “built-in” Joomla “SEF” on many of my sites without issue.

What version of Joomla! are you using, and did you install it yourself, or did you use DreamHost’s “one-click” installer?

–rlparker


#9

[quote]When I enable Joomla’s built in SEO friendly url option, I then get the error:

FATAL ERROR: Unable to read file (/home/myAccount/myDomain.com/administrator/components/com_sef/config.sef.php)[/quote]
I’m confused. In the other message in this thread, you say you are trying to use OpenSEF, but here you say you are trying to enable Joomla!’ “built in SEO friendly url oprtion”. What exactly are you trying to do?

The .htaccess file needs to be setup differently for these two “seo” methods, so it is important that we know which one you are using, and if you have tried one, and then the other, you will likely have to changes your .htaccess file. :wink:

–rlparker


#10

Thanks for the reply rl

Yea as a simpler test case I was set to use Joomla’s built in SEO friendly mode.

I tried different comment out option combinations in
Options +FollowSymLinks and mod_rewrite in use
in .htaccess

still got same error:
"can’t read /myURL/administrator/components/com_sef/config.sef.php

I found a freshly downloaded Joomla install package is missing the com_sef folder in both components folders. are they setup on the fly when sef is enabled, perhaps after switching from openSEO to built in sef it got confused, I could delete the com_sef if indeed they are ceated on te fly.

After replacing the missing config.sef.php file from a patch kit (to eliminte ads in some 3rd party seo component.)

I got the new error

Fatal error: Class ‘SEFConfig’ not found in /myURL/components/com_sef/sef.php on line 1

SEFConfig is at least referenced in that fle, I will probably not be php expert enough in this lifetime to actually debug any substantial code.

Again any suggestions for narrowing rather than widening the possibilities would be appreciated.


#11

I thi9nk your problem is stemming from your previous attempt to install/use OpenSEO.

[quote]still got same error:
"can’t read /myURL/administrator/components/com_sef/config.sef.php [/quote]
This is telling me that the Joomla! system is still trying to use the OpenSEO component, as that file (even that directory!) is not part of the “base” Joomla! install.

No, I believe they are setup with the installation of OpenSEO, and are not needed at all for the “built-in” SEF functionality :wink:

[quote]After replacing the missing config.sef.php file from a patch kit (to eliminte ads in some 3rd party seo component.)

I got the new error

Fatal error: Class ‘SEFConfig’ not found in /myURL/components/com_sef/sef.php on line 1[/quote]
This is a “step backwards” in troubleshooting, and only complicates the issue(s) you will have to sort out.

My advice to sort this is as follows:

  1. Return your Joomla! installation to it’s “stock” codebase, including the .htaccess file.

  2. TO do this you will probably need to uninstall any/all OpenSEO realted components/manbots/modules and make sure that you have all the original files components of the “core” distribution.

  3. Once this is done, and you site is working correctly with no “sef stuff”, you can test the “built-in” sef urls functionality per instructions in the Joomla! backend (check the option in the global config, and rename the htaccess.txt file to .htaccess).

  4. Pay special attention to the .htaccess file at this point, becuase the one you have is very likely “borken.” What is placed in theis file (uncommented, or commented out, and entries) is probably screwed up as a result of your different SEO/SEF attempts.

This process should “narrow the possibilities” for problems to occur, and make it much easier to sort out problems.

One last “friendly” comment about Joomla! and “search engine friendly/SEO” functionality:

Google, and all other major search engines, do not need any of this stuff to properly index your pages. Actually, the whole “SEF” part of “pretty urls” is of little practical use at present; page titles, content, and links are far more important.

That said, you might find that there is little need to install this stuff, and choose to avoid placing the extra load on the server required to rewrite urls.

I don’t want to start a SEO debate here (there as many different informed opinions on that as there are ignorant ones!); I’m only sharing my experience with numerous Joomla! based sites. I have used the “built-in” SEF urls on occasion, and have yet to see it produce better search rankings than using “stock” Joomla! urls. :wink:

–rlparker


#12

I appreciate you taking the time to go into that much detail. the openSEF component says: OpenSEF is Disabled (Off).

I previously used Drupal on a fantastico host, it’s been reported that search engines seem to like it’s more normal out of the box addresses.


#13

You are most welcome, and I hope some of that is useful in getting you sorted out. :slight_smile:

As for the SEf urls, you should most definitely go with waht works for you! This is one of those “holy war” things, and as with most topics like this “YMMV” and the only one you need to please with your decision is yourself/your client! :wink:

–rlparker


#14

(I have a problem for last 2-3 days, when i open my administrator back-end (http://www.byheartsolution.com/administrator) from this link. After that nothing happen and directly my website (http://www.byheartsolution.com/) this will open. So, please tell me how can i open my administrator and update my website.

Please Sir Help…as soon as possible…)