Joomla/AEC Subscription Manager - chown?


#1

Site: http://www.nasarracenia.org

Hello, all.

I’ve searched as many forum posts but have not yet seen a good answer for this. And yes, I know this version is old of Joomla!, but I don’t think I know enough to update without breaking the site.

I’m currently running Joomla 1.0.13 with AEC Subscription Manager by Valanx 0.12.4.8. It’s an account subscription control manager. We just shuttled everything to DreamHost a few months ago and I think this may have created some issues.

When a new user signs up, their payment is received into our PayPal account, but the invoice is no longer “cleared” and their access to the members-only part of the site is restricted. Checking on the settings in the AEC Component, I noticed the following two errors:

[quote]File Permissions Problems

AEC has detected that you are using an Apache Webserver - To be able to hack files on such a server, those files have to be owned by the webserver user, which apparently is not so for at least one of the neccessary files.

We recommend that you temporarily change the file permissions to 777, then commit the hacks and change it back after that. Contact your server host or administrator for the possibly quickest response when experiencing problems. This is the same for the file permission related suggestion(s) below.[/quote]

and…

I’m not quite sure what the first one is referring to, but I tried to fix the joomla.php file permissions problem without success. I accessed the site via ssh, but it appears that “wwwrun” is not recognized by DreamHost. I then tried “www-data”, which it seemed to understand as the fake account, but it looks like changing ownership is not a permitted operation.

Any ideas? This smells to me like the source of the subscription problem if there’s some kind of file permissions issue. This is a bit beyond my grasp, but I can learn quickly.

Thanks for any time and consideration you give to this problem.


#2

I’m not with Dreamhost and have been with the same server for over 3 years. I use Joomla 1.5.23 and AEC 0.12.6 and I started to have some problems with the My Subscription page (some logged in subscribers are not been recognised as subscribers on that page). When I checked the settings the same errors that you have noted showed up. On another site the same problem and I found some database problems with Community Builder. Google brought me here. Perhaps new permission settings with multiple hosts at the start of the year? Coincidence? Will continue to search for the answer.