Joomla 2.5 and PHP "Native Zip"?

apps

#1

Everyone,
I was loading the new Joomla 2.5 (with auto update feature so we don’t have to rely on DH one-click) . One of the features is “Native Zip”

From Joomla’s website:
“This feature adds a check during install to let you know if you have native ZIP enabled on your host. Native ZIP is recommended because it is much faster than using PHP to unzip. The slower speed of using PHP unzip could result in timeouts when you install large extensions or updates.”

Does DH have this feature turned on or can we turn it on for a Hosting account? Being Totally NOOB to PHP i am not sure if i sohuld just submit a ticket to DH asking or take on trying to install this feature? Honestly, unless a security risk, i don’t understand why it wouldn’t be defaulted on?

Question: Is PHP Native Zip allowed to be turned on for a Hosting plan and if so, how would i do it? Would DH have to turn this on or install? If me, (i saw a script for having custome PHP from SXi but it seems you need to load Zip.SO?) then i am totally lost unless someone can point me in the right direction?

Thank you,

Dean


#2

My site was still using PHP 5.2 and Native zip was disabled. The Joomla auto-update from 1.7.3 to 2.5.0 didn’t work. After 2 minutes I had an error. But after changing my domain settings to use PHP 5.3, I found that Native Zip was enabled by default. Tried the update again and it took only 45 seconds and completed successfully.


#3

interesting… 5.3 or 5.3fast cgi? I tried both and my NAtive SQL was saying off… hmmm, may try deleting the folder and rebuilding once more…

Thanks, i will try it.

Dean


#4

5.3 fast cgi


#5

ok, changed the PHP to 5.3 fastcgi, wiped out the www.sitedomain.com folder and ftp’ed the 2.5 contents into that folder froma fresh unzip. Went to do the install…

LOL, i can’t win… (and the world wants me to learn…time to do some google digging i guess…)

Not Found

The requested URL /cgi-bin/dispatch.fcgi/installation/index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


#6

I don’t know what went wrong with your account. I installed Joomla several times on my Dreamhost account without any problems. Maybe you didn’t let enough time to the server to switch to your new configuration?


#7

You still probably have some stuff in your .htaccess for an old custom PHP setup. Look for anything mentioning dispatch.fcgi and remove it.


#8

Correct, Deleted everything and even the the directory and reinstalled. (Hidden file apparently) It worked perfectly… THANKS Everyone!!!