Joomla 1.7 vs. 1.6 vs 1.5?



I see that the last version of the Joomla 1.5 build is available as a one click install at Dreamhost. However, 1.6 has been available for a while and 1.7 was just released with security updates for 1.6 (which had in turn, security updates to deal with 1.5 issues)

Is there any reason 1.6 and 1.7 couldn’t be installed and configured? I’m working on a friend’s Joomla site and am concerned that using Joomla 1.5 may leave her site vulnerable to hacking.




its now an older discussion: but this topics been here before.


I don’t believe it is an ‘older issue’ - it is a current issue for me and should be for anyone considering a cms. Joomla has changed the way it releases new versions and there is no reason to install 1.5x now unless you are committed to using one of the extensions that are not yet compatible with 1.7 such as some of the shopping carts.

If it is a new installation then 1.7 is the go, then a one click upgrade to 1.8 in January. All future upgrades will be one click only.

As migrating from 1.5 to anything higher is problematic, the one click install for 1.5 should, in my opinion, be removed and replaced by 1.7 asap.

As for a manual install of 1.7 on DH the documentation is available at:!_1.7

Informed discussion of the upgrade path for Joomla is to be found at:



Where is my apache config file? More importantly, does it need to be tweaked for joomla?