Joomla 1.5.1 directory path

apps

#1

Hello all.
I tried the one-click install for Joomla 1.5.1 but it seems to pick up a strange path for installing components and modules. My path should be /home/myname/domain.com but Joomla keeps trying to make directories and install to /home/.blah/myname/domain.com.

I read this part in the wiki http://wiki.dreamhost.com/Joomla!#Prepare_to_use_Joomla.21_for_the_first_time:

"In the step 3 page, you confirm the site URL, file path, admin e-mail address and CHMOD settings. All six items on the page are listed below, but you only change three of them.

  • URL: The site URL http://mydomain.com/ should be filled in. You don’t need to change it.
  • Path: A value like /home/.blah/mywebid/mydomain.com should be filled in. Identify the part of the path between the second and third slashes, beginning with a period (".blah" in the example). Delete this part and its trailing slash. The result looks like /home/mywebid/mydomain.com. "

This looks very related to my situation except I didn’t see these options during the Joomla install.

So my question is, is the /home/.blah/myname/domain.com correct (which I doubt given the initial site info sent from dh and the above wiki post) and if not, how do I fix this? Pointers to additional resources would be great…I’m googled out.

In case it helps, I did change from php4 to php5 but that was post Joomla install.

TIA
pab


#2

It is technically “correct”, but you should not use it.

The “.blah” parth of the path is a dataglob, which is subject to change by DreamHost as they arrange clusters and servers. If you use it in your path, should such a change occur, your site would break. If you just use the “/home/myname/domain.com” path (ignoring the dataglob altogether), it won’t make any difference if DreamHost changes it (A link is created at /home/username to /home/.dataglob/username).

How you fix it depends upon where you are in the Joomla! install process. You can change it when you first install Joomla! or, if you missed that (it’s an ajaxy “advanced” setting thing that is easy to overlook, IIRC), you can change it directly by editing the Joomla! config file on your server.

–rlparker


#3

Thank you rlparker. That resolves my concerns and increases my understanding. My paths in my joomla config point to /home/name without the .blah so I should be set up correctly.

Any install issue I may have in the future will be squarely a Joomla one…or me :wink:

Thanks again,
pab


#4

You are welcome, and good luck with your project. :slight_smile:

–rlparker