Joombla one-button install doesn't work


#1

I just spent an hour on the Joombla forum.

Basically when you do the one-click (ha!) install correctly, it wants to save to a tmp director that is unwritable. Problem is…there is no tmp directory! I’m told after --a lot-- of research that I need to edit the save path on my php.ini file. Guess what? That file does not exist either.

ANYONE get this software package to work??


#2

Did you search this forum?

Check this link for information relating to your issue.

Good Luck
–rlparker


#3

I hope this reply does not show up three times. I keep trying to reply but it does not work. Basically that thread was just many users having the same problems. One person proposed moving to php4 but other programs require php5 so this is not a solution. I think a one click install should be easier than this.


#4

ok… I give up. :frowning:


#5

I checked out the thread you linked to. I’m having identical problems. I’m NOT on PHP 5 and yet the Session save path is: “/tmp, Unwriteable”.

If I continue with the install, the admin login box loops. Please help!

Also, I sent you a PM about those notes you mentioned in the other thread… :slight_smile:

If anyone else has any info, please do share!


#6

have you tried to chmod the directory to 777?

The Insane Cabbit
Blog: http://www.sounanda.com
Store: http://www.marciesgifts.com
PM for CMS or forum install.
[color=#CC0000]$97 Off[/color] with promo code pixiedust


#7

chmod which directory exactly? The /tmp directory? How do I do that? The directory is not in my /home/username nor is it in /home/username/username.com - how exactly would I chmod the directory?


#8

You will not be able to change the permissions on /tmp, as you are not the owner of that directory. It is above your “home” directory and is owned by DH.

I’m thinking something isn’t right with your server configuration. I just installed a new instance of Joomla 1.08, as a test to see if something was “newly broken”, via oneclick and it worked like a breeze.

I’m running php4 as PHP-CGI. /tmp is writable, all works! There must be something different in your set-up - we just have to figure out what it is.

–rlparker


#9

I’m an embarassingly noob user.

I got my gallery one-click to work, as well as Joomla.

I have to admit., I found the online guides & default guide/411 emails, VERY EXACT, and helpful. No problems here :slight_smile: YAY.

My only gripe with DH, is that they don’t offer a one-click HOME PAGE thingy. :frowning: I REALLY NEEDED THAT. When I was with 1and1., they had that…but alas didn’t have a wicked online gallery thingy to use :frowning:


#10

Just a thought. While helping another user with similar problem, it turned out he was trying to install joomla as only an FTP user, rather than as a shell user. The ftp user has less permissions than a shell user, and that would make the CGI process run under the ftp user’s permission.

Try creating a shell user, login with that, and repeat the process. I think you will find that /tmp is writable now.

Good Luck!
–rlparker