Javacript Enabled?


#1

Hi, I just posted a temporary web layout on my site Dorstudios.net and on the right of the table there is a navigation bar that its splices rollover through an pre-made javascript generated by dreamweaver. (it’s obviously there if you look at the page source) However, not even the pictures are showing up. Is javascript enabled through dreamhost? The entire page shows up fine when I view in on my desktop but not on the internet. HELP PLEASE.


#2

Well your problem doesn’t help find a solution when there is nothing to look at!! hehehe

JS is a client based scripting language, which means it has nothing to do with the webhost. I’d re-upload everything again. Images and html… I know it’s a simple/obvious reply but that’s all I can think of.
There seems to be a lot of junk in the HTML itself which is probably what DW put in. Things like

alt="" name=“undefined_2”

You could remove them I think and it should be ok.

Just noticed. You might need to close your iframe tag. Straight after the closing tag of the iframe, put . See if that works.


#3

Lol Thanks for the help anyway.

Yeah, Ive never had problems with my generated script before usually its the ones I write I have most issues with.

Usually all that alt tag and whatever garbage doesn’t affect the functions and I get too lazy to delete it haha

did I not close my iframe tag? I’ll check again. Its problem just not functing because I didn’t close something. I give the page a look over again for loose tags. Thanks again.


#4

JavaScript is a client-side scripting language. The server running the script has no value in whether or not JavaScript displays [improperly or not].

The script may be structured incorrectly, or has an error somewhere within the JavaScript. If your computer/browser does not have JavaScript enabled, enable it via Internet Explorer using Tools > Internet Options…

The main point here, though, is… JavaScript works depending on what the viewer has, not the host.


#5

I know that it can depend on the browser but my question was pertaining to dreamhost only.

It doesn’t matter anymore because my some weird miracle, its fixed.

thanks anyway though.