Jabber IM problems


#1

The DH Goodies include Jabber IM services using my own domain. I’ve tried this but didn’t succeed. I have tried different clients for Windows including Exodus and Trillian Pro. With Exodus I managed to come online using a public Jabber server (torbengb@jabber.dk I believe), but never with my torben@g-b.dk Jabber account that I have on my DH-hosted domain. Trillian says it’s online, but other Jabber users see me as offline so I don’t believe Trillian’s status.

The Jabber page in the Web Panel says the account is active, but I can’t succeed anyway.

Help?! What could I do to find out where the problem is?


TorbenGB


#2

This is not much help but both my partner and I have domains and Dreamhost and we both use Jabber. So it does work.

As you can connect to a public server shows the problem is not on your client.

In the dreamhost control panel, in the domains tab is jabber active for the domain?

Tancred


#3

I never expected that the DH-hosted Jabber wouldn’t work – it’s just a matter of me learning how to configure it.

Yes, in the Domains tab there is a “Jabber” service type for my domain (which is a fully hosted one), but I don’t recall seeing it before. Additionally, the status is “new” and the “Reconfigured (PST)” is blank. Is this the expected status? I can click “edit” which returns me to the Jabber IM tab referenced in the first post, but that looks okay to me.

Note that I created (and activated) the Jabber account on my domain months ago, so it’s not just a matter of patience. I started playing with DH-hosted Jabber but it’s only now that I really tried to get it working.


TorbenGB


#4

I’ll contact DH Support for this. Thanks to a friend online and some testing, it appears that my domain’s jabber feature works fine, except that I appear as offline to the outside world… Testing showed that the applications I use are not at fault. Thanks for the input though.


TorbenGB


#5

TorbenGB,

Can you tell me which server you are on? I’m on Vidar and it has major Jabber problems. Often the server2server connections don’t work. Currently the Jabber server for my domain is failing to connect to jabber.com, elstat.net.pl, charente.de and amessage.ch - so anyone on these systems will see me as offline.

I have raised this serveral times with DH support over the past few months, and they have never seriously looked at it. It’s very disappointing. I am hoping they will upgrade to jabberd 2 at some stage and that will fix the issue.

Zilch


#6

I am on salt.dreamhost.com. I submitted a support request through the panel that has been passed on to a tech guy. I got a mail about that but still no news, and the support ticket notes that it’s been open for 3d15h now.


TorbenGB


#7

OT here a bit, just wanted to throw my hat in the ring and say I find the waning support for Jabber a real bummer. It was Dreamhost’s enthusiasm in launching and promoting it that got me interested in using it in the first place. Now they seem to pretend it doesn’t exist.

I tried off and on for a few months to use the service without any reliability and have long since given up on it.

/end whining

[color=#0000CC]jason[/color]


#8

Can someone from DH comment on the Jabber support? Is there just a lack of Jabber skills with the staff - or a lack of interest? Has jabberd 2 been tested? Has anyone checked to see if the S2S problems are limited to one or two servers?

I’m happy to give people a hand with client side Jabber problems, but the server side of things is why I have a DH account.

Thanks,
Zilch


#9

boing.

I wonder if this is getting any attention at all from Dreamhost. So far my support ticket has been open for 7d19h … this is not DH’s usual style.


TorbenGB


#10

I’ve heard from DH support now:

[quote]> I’m working on upgrading the jabber daemon to a newer version but it’s

[quote]been problematic. I expect to have it working this week. I apologize for
the delay.[/quote]
[/quote]

So there – I hope we will all get a nice and smooth Jabber soon. I’d rather have good service than quick service, so I’ll be waiting patiently for this. It would have been nice of DH to keep us informed of their work on it though, to keep people patient and happy.


TorbenGB


#11

Don’t hold your breath - I got this:


(2004-02-10 07:09:57 / #2306690)

Hello,

Sorry it’s been a while since you’ve heard from us. We still haven’t found a solid reason why jabber would be timing out, but we’re going to try to upgrade jabber this week. With any luck, that will fix your problems.

We’ll keep you posted.

And that’s the most recent one - more than a month old and Jabber is still on 1.4.2.

Strangely everything seems fine today - not sure how long it will last though. Everything worked fine when it was first installed too - I suspect it is the server running out of ports (?) or something simple…but if they want to upgrade it who am I to complain.

Zilch