Jabber + Gaim not working


#1

I sent this off to support a couple days ago and am waiting on a response from them. In the meantime, maybe somebody else has had the same problem and could help me out.

I just created a Jabber user, im@mydomain.com. That user is currently active. I’m using Gaim and whenever I try to connect to the Jabber server, it goes through the connection process and right after the blue bar finishes, I get the following error:

im@mydomain.com/Gaim has been disconnected.
<Date & Time>
Stream Error
RECONNECT or CLOSE

Here are my Jabber settings in Gaim:
Protocol: Jabber
Screen Name: im
Server: mydomain.com
Resource: Gaim (tried Default too)
Use TLS if Available (tried checked/unchecked)
Port: 5222
Connect Server: mydomain.com

I’m using the latest version of Gaim and am currently connected to ICQ, AIM, and Google Talk using it. DH Jabber is the only one thats giving me problems.

Any idea how to fix it? I’ve checked the Knowledge Base and the Support forum, no luck. Thanks.


#2

I’m not a Gaim user but your screen name or JID should be im@mydomain.com.

happylittlethings.com
Promo Code: WJD50 - $50.00 off any new DreamHost plan


#3

It’s a little strange in Gaim. The “server” and the “connect server” are different.

If I do this:

Screen Name: im@mydomain.com
Server: mydomain.com
Connect server: mydomain.com

Gaim will try and connect to mydomain.com using "im@mydomain.com@mydomain.com" as a screen name. So the ‘server’ field refers to the part after @.

They should rename the server field, it’s confusing. Google Talk works fine using the same principles as I mentioned.


#4

Hi Spoon69,

I’m currently experimenting with the DH jabber server and various clients. So far Gaim is working fine for me. I have 2 copies of Gaim logged into two different DH jabber accounts and can IM back and forth fine. One diffence in my setup, I didn’t fill in anything for the ‘connect server’, only the ‘server’ as mydomain.com. Maybe that will solve your problem.
–patrick


#5

OK, problem is fixed, thanks DH Support (John specifically). Nothing wrong with my Gaim setup (other jabber clients gave errors too), it was some jabber service/hung process thing with my server. All is well now.


#6

So I have to email support to have this fixed? I’m having the same “stream error” issue using gaim and psi.