Issues with wordpress cache plugins

wordpress

#1

Hi,
From around September 15th I’m having issues with wordpress cache plugins, none of seem to be working. On the surface everything seems to be OK. I can access my website and view pages however they block search engines bots, more importantly googlebot. As a result my ranking is totally screw up. I did try W3 Total Cache, WP Super Cache, Hyper Cache and none of them work.

Before September 15th I was using W3 Total Cache which worked great, after I learnt that bots were being blocked I thought it was an issue with W3TC and switched to WP Super Cache and then Hyper Cache however the problem did not go away.Which makes me think that this is not a plugin issue but rather server or compatibility issue with the latest wp 4.0

Could someone please look into it ?
Thanks
P.S. I’m on shared server if that helps.


#2

Hi, not sure if this is what you’re looking for but you might want to check below.

http://wiki.dreamhost.com/Robots_Exclusion_Standard


#3

Thanks for the reply, my robots.txt is not causing the problem.


#4

What’s your domain?

Google did a change to things in September, of course, and weird things have happened to people.


#5

maybe add sitemap to google
or view in google webmastertools if the page does not have a filter


#6

Hello,

Did you finally managed to solve this? I have exactly the same problem. I was using wp-super-cache, suddenly it stopped working and now no caching plugin works!! I have tried almost everything!