Issues with SMF and SMTP. Please help!


#1

I honestly can’t tell if the problem lies with the SMF or Dreamhost sides of things, so I’m going to start here.

I set up a forum with SMF and set it to e-mail activation. Unfortunately, new users don’t get said activation e-mails. I Googled the problem, and as far as I can tell, everything is fine on the SMF end of things. Everything points to how my hosted server handles e-mails. Since the PHP default isn’t working, I set mail options to SMTP and filled in the proper fields:

  • I set the SMTP server to both mail.[mydomain] and mail.[subdomain.mydomain] (where the forum is hosted) and got no results when attempting to send myself a notification from the forum.
  • The port is set to 587 instead of the default 25 for good measure (please tell me if I need to change this).
  • Username is the full e-mail address of admin@[subdomain.mydomain] (again, where the forum is hosted).
  • Password is entered accordingly.

Until I can somehow fix this, no one can register without direct admin approval, and the current registers are stuck in “awaiting activation” purgatory.

Is this a problem on my end? Did I set up the SMTP correctly? I really appreciate the help!


#2

Port 25 should be fine.

Is admin@sub-domain.domain.tld a real mail account? Double check that the password is correct.


#3

Yeah, the e-mail is perfectly fine. I am, however, getting this set of errors on SMF:

2: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to mail.[domain]:25 (php_network_getaddresses: getaddrinfo failed: Name or service not known)File: /home/[user]/[domain]/forum/Sources/Subs-Post.php Line: 1332
and

Just to make sure, I changed the e-mail server to mail.[subdomain.mydomain] and got this error:

Can you help me better understand what this stuff means? Thanks again for your assistance!


#4

The first errors are saying mail.domain.com doesn’t exist - but that’s of no concern here.

The last error indicates that you are at least successfully connecting to a mailserver - so keep using that one.

Alter the “From:” field in whatever interface you’re using in SMF so that it specifies that the mail is from admin@sub-domain.domain.tld


#5

Alright, I’ve set the mailserver address to the latter (thanks for that!), and I changed the port to 465 at the suggestion of an SMF support user, and now I’m down to a single error:

I feel like I’m getting closer to having this solved. Any thoughts?


#6

Not without seeing the code that’s handling the mail. Could be EHLO or something.

Look through your settings and ensure the same email address is configured everywhere (forum/webmaster/whatever settings).