Issues with Icecast on Ubuntu

dreamcompute

#1

I’m setting up an icecast server on the US-East 2 cluster. I have been successfully running it for quite a while on the US-East 1 cluster for quite sometime now. Everything seems to be in order with the exception that when i attempt to access the Icecast status page on port 8000 (the icecast default) the browser just hangs and then times out.

After running a scan I get:
22/tcp open ssh
80/tcp closed http
443/tcp closed https

When I initially put the old icecast sever on US-East 1 I did not need to specifically open any ports or create any special services, I simply installed icecast via apt-get, did my config and started the icecast server and everything worked. For this latest instance I used “Quick Launch” and selected Ubuntu (I also tried Debian but had the exact same issues) and am currently running Ubuntu-16.04.

I’m sure whatever the issue is its a very small tweak but I’m at a bit of a loss atm. Any suggestions are VERY welcome as I’d like to get this up and running by Monday. Thanks in advance for your help.


#2

You need to open port 8000 in the cloud security groups. Check the new UI on https://cloud.dreamhost.com and use that to open the port 8000 (or, if you feel like venturing in the trenches, follow the docs on https://help.dreamhost.com/hc/en-us/articles/215912838-How-to-configure-access-and-security-for-DreamCompute-instances)


#3

Thanks so much smaffulli I’m looking at it now.
[hr]

THAT WORKED!

Thank you so much :smiley: