Issues with FusionBB 1.0

apps

#1

I’ve recently installed FusionBB for testing on a new subdomain of mine. It works beautifully…except for one nagging issue.

file_get_contents()
and
"URL file-access is disabled in the server configuration"

Yes, I’ve read the previous threads about this being disabled as well as the Wiki entry with “workarounds”. However, I wanted to know if anyone else had tried FusionBB on DreamHost and figured out a way around this issue.

I posted about this in the FusionBB support forum:
http://fusionbb.com/forum/showtopic.php?tid/4013/

The response was essentially “Yeah, I’m not sure how else to fetch a remote file, if you can’t fetch a remote file. I’ve never seen a host disable this though… and I’ve worked on a lotta sites.”

Yeah, really helpful. … :frowning:

…and so now I turn to the DreamHosted masses for help. I know Perl programming, but zero PHP…so I’m kinda stuck.


#2

well, the best way around it is to follow the directions in the forum and wiki to convert the url fopen to a curl statement. More and more hosts are disabling this feature becuase it’s a secuirty risk.

You could also compile your own version of php and enable fopen. Instructions for installing php can be found in the wiki.

-Matttail


#3

It might help if you post some code for us to look at.


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]