Issues with DreamCompute and ServerPilot

dreamcompute

#1

DreamCompute and ServerPilot tend to get things flowing smoothly, but as of this weekend, the duo is not getting along.

Has anyone else attempted a new instance with ServerPilot?

I cannot seem to get past this point: https://goo.gl/GZSZxq (file is a jpg of a screenshot)

Anyone know of any workarounds?


#2

Looks like the VM is not connecting to security.ubuntu.com. Is that a temporary failure? did you check if you can connect to it outside of apt? Does this happen on other VMs? can you trace the path to security.ubuntu.com to see where things stop?


#3

Upon further investigation, it looks like this was a temporary issue with IPv6 connections. The issue has been solved and a newly booted machine doesn’t have issues accessing mirrors. Your image should work too now. If it doesn’t, try disabling IPv6:

and try running apt update again.


#4

I too experienced this issue.

What fixed it for me was to reboot the instance and then run the ServerPilot script.

That being said, I also had an instance that just wouldn’t take to ServerPilot. Terminating and spinning another up solved it. Not sure if something happened when the instance received its IP or it was delayed.