Is there a log file for FTP errors?


#1

Hi,

For a week or so now I’ve been unable to FTP into any of my domains on my DH shared server (bigtop) - every time I try I get error 530 (maximum 10 connections already) despite having closed connections for all FTP users via the DH control panel - I’ve done that a lot now lol! I’ve tried different FTP apps, different PCs (on same network) with the same results. It was working 100% for a few years up till now, and this problem strangely seems to tie in with the move to Ubuntu but that could be a coincidence.

A friend on a different ISP can FTP into the domains and DH support say they can too (and that my IP is not blocked), so it’s something else - I get the feeling this “maximum connections” error I am getting back is not the real problem.

So, to cut to the chase is there an FTP log file I can see login attempts and its errors? Thank you.


James


#2

Hi James, try these.

[quote]/var/log/messages : General message and system related stuff
/var/log/auth.log : Authenication logs[/quote]


#3

Hi peleus, and thank you for your post. Unfortunately I can’t see /var/log/messages, and when I try to access auth.log (e.g. more /var/log/auth.log) I get permission denied error. I’m on a shared server using a shell user I created.


James


#4

@james999 - can you switch to SFTP? If so, then navigate to your user in the panel and “disallow ftp”

If you don’t know why your ftp sessions are quickly filling up, you might want to go ahead and change your users password too.


#5

Hi LakeRat,

Thanks for your post. Yes, I’m using SFPT as a workaround for now. But it’s SO SO much slower though than FTP (I need to upload/download MB sometimes and it’s painfully slow with SFTP, at least to shared server bigtop). Re number of connections - I have 20 domains all on the same shared server, all small sites, and suddenly I cannot connect via FTP to any of them, every time getting that max connections error. But that error does not occur with people connecting to the same FTP servers from elsewhere (e.g. a friend of mine located in another part of the country). So that error is either incorrect or there is some other cause of it, and as I say killing all FTP connections on all sites does nothing, despite trying it 5 times now. So it could e.g. be something to do with my ISP. Then again I can FTP to other domains fine, even ones on a dedicated DH server. That’s why I need to see the logs, so I can try to work out what is actually going on with this shared server’s FTPing.

Bottom line still I think really is that I would be very grateful if someone could please tell me how to access the logs of FTP activity on a shared DH server? Thanks very much in advance! :slight_smile:


James


#6

What does the clients log show you? I haven’t used ftp in years for security reasons, but back when I did I can’t remember an issue I couldn’t diagnose reading the client log and/or a traceroute.

FWIW if you are getting too many connections, and someone with a different IP doesn’t get the error, how many concurrent sessions are you trying to open?


#7

Thanks for your further post, LakeRat. Very much appreciated.

I’m trying to open a single FTP connection - that’s an option in my client FTP program (Core FTP LE) and it’s checked. Here’s the log from that client (I get very similar results using CuteFTP as the client too):

Resolving abc.com
Connect socket #1160 to 66.33.214.229, port 21…
530 Sorry, the maximum number of connections (10) for your host are already connected.
Can’t establish connection --> abc.com:21 @ Mon Oct 27 17:07:27 2014 (0-2)

Tracert log is this:

Tracing route to abc.com [66.33.214.229]
over a maximum of 30 hops:

1 3 ms 1 ms 1 ms 192.168.0.1
2 10 ms 8 ms 9 ms 10.158.72.1
3 8 ms 9 ms 9 ms bmly-core-2b-xe-132-0.network.virginmedia.net [80.1.225.177]
4 32 ms 10 ms 9 ms brnt-bb-1a-ae13-0.network.virginmedia.net [213.105.159.229]
5 47 ms 45 ms 49 ms brnt-bb-2a-ae2-0.network.virginmedia.net [62.254.42.97]
6 13 ms 13 ms 48 ms brhm-bb-2b-ae0-0.network.virginmedia.net [62.254.42.58]
7 13 ms 13 ms 13 ms brhm-bb-1b-ae4-0.network.virginmedia.net [62.254.42.206]
8 18 ms 19 ms 21 ms teln-ic-1-ae0-0.network.virginmedia.net [212.43.163.250]
9 38 ms 31 ms 31 ms m282-mp2.cvx3-a.ltn.dial.ntli.net [213.104.85.26]
10 30 ms 30 ms 29 ms be2494.ccr42.lon13.atlas.cogentco.com [154.54.39.130]
11 101 ms 102 ms 101 ms be2394.mpd22.jfk02.atlas.cogentco.com [154.54.30.169]
12 109 ms 109 ms 112 ms be2151.mpd22.dca01.atlas.cogentco.com [154.54.40.73]
13 112 ms 105 ms 105 ms te0-6-0-5.rcr21.iad02.atlas.cogentco.com [154.54.31.190]
14 108 ms 107 ms 107 ms te0-0-0-0.agr12.iad02.atlas.cogentco.com [154.54.44.202]
15 107 ms 115 ms 111 ms te0-0-2-3.nr11.b037327-0.iad02.atlas.cogentco.com [154.24.15.66]
16 115 ms 103 ms 103 ms 38.122.62.254
17 108 ms 109 ms 106 ms ip-208-113-156-8.dreamhost.com [208.113.156.8]
18 107 ms 107 ms 109 ms ip-208-113-156-14.dreamhost.com [208.113.156.14]
19 111 ms 107 ms 108 ms apache2-grog.bigtop.dreamhost.com [66.33.214.229]

Trace complete.

Just to add in case it’s relevant, apart from FTP, my domains on this shared server all seem to be working fine.

One more thing I tried - I can webFTP into it fine too with FTP protocol selected.


James


#8

Hi,

Just in case anyone has the same issue in the future and finds this thread, it was solved by Dreamhost Support restarting the FTP service on my shared server. They told me it happens occasionally on the servers since they moved to Ubuntu. Now I can connect ok to FTP on all my domains on that server.


James