iPhone Mail


#1

Some of you may be aware that there is a problem sending mail with the iPhone with certain ISPs because of port blocking (25). I’m a Comcast user, and they have that problem.

It’s been suggested that I try to use port 80. So my question is whether Dreamhost smtp server (guile in my case) uses port 80, and whether “smtp relay” is part of the service. If so, I can use my Dreamhost e-mail account for outgoing mail with the iPhone.

Ken

Ken


#2

This link has lots of info on how to configure many clients - none specifically iPhone but certainly should tell you ports and configuration that should work.

http://wiki.dreamhost.com/E-Mail_Client_Configuration

The meat of this is:

(Note, if you prefer POP3 access, use port 110 for normal/TLS access, or port 995 for SSL access.)

Note that port 25 access is not necessary and SSL/TLS is available on specific ports.

Wholly - Use promo code WhollyMindless for full 97$ credit. Let me know if you want something else!


#3

Thanks for the reply, but it’s a bit over my head. Would you be willing to explain it in a bit simpler terms?

I guess what I’m looking for is the specific address and port for the outgoing smtp server at Dreamhost.


#4

The reason I’m specifically interested in port 80 is because many hotels and public hotspots block all ports except 80. I could use my gmail account, because gmail does use port 80, but there are other issues associated with that.


#5

Try port 587 with mail.yourdomain.com as the host. This is designated as the port for mail submission (ie, end users sending email). You will also have to use SMTP authentication.

Larry


#6

Thanks, I’ll try that. Just to make sure we’re on the same page, my normal setting for outgoing mail is smtp.comcast.net. Are you saying that I should try setting this on the iPhone to mail.comcast.net:587?


#7

No, your outgoing mail should mail.YOURDOMAIN.COM. You probably currently use comcast.net because comcast is blocking port 25 for outgoing mail, forcing you to use their outgoing mail server only.

-Scott


#8

Sorry for being an idiot, but just to make sure I have this right, I should set the outgoing server to:

mail.yourdomain.com:587?


#9

That’s right (replacing “yourdomain” with your registered domain). You also have to setup SMTP authentication. (You can optionally setup TLS/SSL support if the iPhone supports it.)

Doing it this way will maximize the chance of it working regardless of where you are.

Larry