ionCube Help

apps

#1

Hey All,
I’m trying to get ionCube up and running and I’m having no luck. I need it for a 3rd party calendar application that my site runs.

Anyways I’ve gone through the PHP.ini setup in the Wiki as well as the IonCube setup in the Wiki and for whatever reason I can’t get it to load the library.

All the paths are correct and when I do the “phpinfo” thing it even looks like it’s using my php.ini that has the zend_extension pointing to my lib. From what I’ve read this should be working…but it’s not.

Any ideas?

Thanks,
Jared


#2

This still isn’t much to go on. ionCube has been discussed here many times before. Do a search on “ioncube” in all forums in the past year and see if any of that helps. Being that it’s closed source, you’ll not find many people super eager to jump in and help.

-Scott


#3

Ah, the search defaults to only 1 week…didn’t realize that.

I’m not too eager about using ionCube either.

Thanks,
Jared


#4

O.k., I’ve done some additional searching and changing things but still no luck.

I’ve changed over to PHP 5.2 from 4.4 and redid the .htaccess as well as re-edited the php.ini. I’ve manually created the .htaccess and php.ini stuff to override the provided php.ini, I’ve also used the script that is provided on the wiki page to over ride the php.ini.

According to the Phpinfo() the ini is being used, so I’m confident I at least didn’t screw up that part. However if I run the php.cgi I receive an error about it not being able to find the ioncube library. Here’s a terminal dump:

[bugsy]$ ./php.cgi
Failed loading /home/un/ioncube/ioncube_loader_lin_5.2.so: /home/un/ioncube/ioncube_loader_lin_5.2.so: cannot open shared object file: No such file or directory
X-Powered-By: PHP/5.2.6
Content-type: text/html

[bugsy]$ ls -la /home/un/ioncube/ioncube_loader_lin_5.2.so
-rwxr-xr-x 1 un pg1676772 982084 2008-05-17 13:51 /home/un/ioncube/ioncube_loader_lin_5.2.so
[bugsy]$

Here’s the bottom of the php.ini file:
zend_extension="/home/un/ioncube/ioncube_loader_lin_5.2.so"
zend_extension="/usr/local/dh/apache/template/phpext/ZendExtensionManager.so"
zend_extension="/usr/local/dh/apache/template/phpext/zend_optimizer5/ZendOptimizer.so"

Obviously it exists (as seen in the ls). I’ve re-uploaded the IonCube package and blown it out on the server. Everything should be working and happy…maybe the permissions are wrong? But I’ve moved them around a lot and nothing seems to work. I’ve also moved the library all over the place and nothing seems to matter there either. Any ideas?

Thanks!
Jared


#5

Anybody? I’ve since disabled the application that requires ioncube so the site is back up and running…still I would like to have our calendar back.

Thanks!
Jared


#6

Hmmm…10 days and still no takers for your ionCube problem Not surprised.

-Scott