Invisible htaccess file?


#1

I tried to upload an .htaccess file into a subdirectory, and the log said it was there, but it didn’t show up in the directory list (using lftp).

I changed the file name to htaccess.txt (which I had to do with a previous domain host) and it showed up. When I changed the name back to .htaccess it disappeared.

How can I get .htaccess files to behave?


#2

Your FTP client is /probably/ configured to not show hidden (.*) files. I don’t use lftp so I don’t know where or if there is an option to turn this off.

Don’t worry if you don’t see it, though. The file should still be there and should still ‘behave’ or influence the servers behaviour as you instruct it to.

  • wil

#3

I googled and found this:

http://www.gsp.com/cgi-bin/man.cgi?section=1&topic=lftp

Search the document for tp:list-options and you should find your answer.

  • wil

#4

Will

That did the trick! Exactly what I needed, thanks.