Invisible .ht files


#1

I’ve sent a support ticket about this but after over a day still no answer, so maybe somebody can answer here?

I’ve just moved my main site here. Several of the directories have .htaccess and .htpasswd files in them, and although they are functioning and so are clearly there, I can’t see them either in ftp (cuteftp) or telnet. Is this a normal behaviour of the system, and is there any way to override it?

It’s kind of difficult to modify a file I can neither see, nor download… and since the .htpasswd files are updated constantly by my payment processors, I can’t just keep local copies.

Any help greatly appreciated on this one!


#2

most ftp clients won’t display invisible files or files with a ‘.’ in front of them. check your prefs in the ftp client that you are using and tell it to show invisible files.


#3

It’s normal, its documented, etc etc

anyways

In shell (telnet/SSH):

user@machine:~/example.com$> ls -a . .. .htaccess .htpasswd

In CuteFTP, you need to look for “server-side filtering” setting. Well, at least that is what is called in CuteFTP Pro. Access Site Properties, then Actions tab, and there is a “Filter” button.
On this dialog at the bottom is “server-side filtering” with a checkbox and textbox. Check the checkbox and in the textbox put “-a”

If you monitor the FTP commands then you should then see your client send “LIST -a” when retrieving a directory listing.

:cool: Perl / MySQL / HTML+CSS


#4

Thanks for the replies. A google did tell me that this is normal, what confused me was that I’d never had to set anything in cuteftp before so I didn’t really understand what was going on. I’ve enabled -a in cuteftp on this site and now its working fine. What’s now confusing me is that my other host (Velcom) is now the same in cuteftp (invisible files invisible) even though it wasn’t a couple of hours ago.

As you may have guessed, I have no idea what the hell I’m doing. Many thanks for the replies.