Invalid SSL for SMTP


#1

I was wondering if anyone knows how to get around this issue. I have iMail setup (on OS X) to do my e-mail with my Dreamhost account and it works great. I’ve got both sending and receiving doing SSL. Now here is the issue.

Whenever I send e-mail, I get a big dialog box telling me the SSL certificate can not be trusted and that someone might be pretending to be “mail.foobarsoft.com” (my domain). I can view the certificate (given to mail.dreamhost.com) and such, and click a help button, a cancel button, or a “go ahead anyway” type button. If I click that (which I do) then the e-mail goes out just fine. But having to do this each and every time I send e-mail from this account is annoying and I don’t want to turn off SSL.

Does anyone know how I can get iMail to stop warning me about this?

PS: Why isn’t it doing it when I check my mail? I’m using a proxy called POPFile that does the SSL part for me. As far as iMail knows I’m doing unencryped POP3.

– Michael Cook