Internal server error


#1

Nothing has changed on my website in the past week but today I started receiving:
[Mon Apr 16 05:14:53 2012] [error] [client xxx.xxx.xxx.xxx] FastCGI: comm with (dynamic) server “/home/htmluser/mydomain.com/cgi-bin/dispatch.fcgi” aborted: (first read) idle timeout (60 sec)
[Mon Apr 16 05:14:53 2012] [error] [client xxx.xxx.xxx.xxx] FastCGI: incomplete headers (0 bytes) received from server “/home/htmluser/mydomain.com/cgi-bin/dispatch.fcgi”

(edited to protect the innocent)

In control panel I have apache running as CGI and NOT FastCGI, so I’m not sure why the dispatch.fcgi is running. Any help tracking down the issue would be much appreciated. FYI, I already create a support ticket but thought I’d work it from 2 angles in hopes of coming to a quicker resolution.[hr]
I was told that I had a hung PHP process and that the process was killed. That’s great. But I’m still getting the errors. If I restart Apache the server will run fine for about 1-2 minutes until the errors reoccur. Any idea on how to track down the problem so I can fix it permanently? I’m at a loss…


#2

No one has any ideas? I tried changing the domain to use mod_php but the change doesn’t seem to take effect. Still getting FastCGI errors in the error.log file but indicates that the change didn’t take. Ideas? I’m really stumped and need to get my website up. So far the 3 tickets I’ve created with tech support have gone unanswered.


#3

They seem to be having a problem with the database server(s). My site is generating errors and MyPHPadmin won’t work at all.

I sent in a trouble-ticket so I’ll see what’s up.[hr]
The problem seems to have been resolved for me, the database server is working properly again.


#4

Yea, my server is still having issues. =/ Restarted Apache several times, with the same result. Need some way to troubleshoot which php file causes the php processes to hang. Alas, I’m unsure on how to do that.


#5

My sites are all slow, seems to be something up… I thought it was my Cloudflare test site but my non-Clourflare sites are slow too. 30 seconds to load a forum page, normally they are 1 second.


#6

Open your .htaccess file and remove (or comment out) the directives that are loading your custom PHP setup.