Internal Server Error WP 2.0.7

wordpress

#1

http://www.eConsultant.com/blog/

I started getting getting 500 Internal Server Error a couple of days ago when I spent the night manually writing 300+ blog entries.

The error log just says:

Premature end of script headers: php5.cgi

  1. I have used Top and killed off all the php5 processes

  2. I upgraded to WP 2.0.7

  3. I deleted all the plugins except wp-cache which was needed. I am using the Default 1.5 theme with no plugins.

  4. I tried the Saved my domain.name on the domain panel - to rewrite the htaccess etc

  5. I tried going back to PHP 4

I can go to the blog Dashboard but the blog home page will not load.

None of the above steps have made the error go away.

Any ideas.


#2

Maybe check out your .htaccess file? You could save a copy of it, then delete it and see if it works okay. If so, then that’s probably where your problem is.

When you upgraded to 2.07, did you run the update script? Probably at: http://www.eConsultant.com/blog/wp-admin/upgrade.php


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#3

Yes, I used the upgrade and got a successfull upgrade.

At your suggestion, I renamed the the .htaccess to htaccess.txt and still, the blog won’t load.

I have logged a ticket.


#4

I just noticed that it also returns a 404… is your index.php file in the /blog directory? I’m just wondering if something went wrong with the upgrade.

Also, what version were you using before the upgrade?

How about plugins? Did you disable all of them before upgrading? If not, since you said you can access the panel area, maybe try disabling all plugins and see if that helps. If so, enable them one-by-one until you hit the one that causes the problem.

Otherwise, support should be able to figure it out. If your setup isn’t too customized/modded, you could just delete the directory and re-install it. It should just connect right back to the DB when you add the config info… but someone smarter than me would probably back up the DB first, just to be safe. :wink:


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#5

There is an index.php in /blog/

I was on 2.0.6 before this;

I upgraded via the 1 click install; I got a success screen.

I deactivated all the plugins then I deleted them from the folder.

There are no active plugins in the folder except wp-cache - even that I have tried with activated/deactivate state.


#6

Well, since you already had 2.06, there probably shouldn’t have been any compatibility issues with the plugins.

I can’t think of anything else off the top of my head, especially since it wasn’t the .htaccess file–unless something was corrupted during the upgrade.

Personally, I like the one-click installs, but I’m not a fan of one-click upgrades. The Wordpress site has very detailed & easy to follow upgrade instructions. Not that it was part of the problem, but you might want to read through them and see if you’d prefer to give it a try next time there’s a new version released.

Let us know what support finds, if you don’t figure it out before they get to it.


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#7

That’s also my feeling; the “one-clicks” are “dead-easy” convenient (though it is frustrating they require a completely empty directory!) but I like more control over the upgrade process.

Generally, I’ll use a one-click to install, but then manually manage upgrade processes from there. Once you have manually upgraded, you can’t then go back to “one-click” upgrading reliably anyway.

–rlparker