Internal Server Error PHP.ini/.htaccess issues


I review and write about CRM solutions. I was recently preparing an article on InfusionWP, a WordPress plugin that uses Infusionsoft CRM to create a membership site. I created a sub-domain for this test and let the software vendor handle the installation-setting up php, ioncube, etc. Things went just fine but I started getting 500 Internal Server errors as below:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error. More information about this error may be available in the server error log. Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I started following through the email DreamHost support sent me to optimize my WP site. I also decided to move InfusionWP to a production sub-domain (

This is when I first observed a new error message: Site error: the file /home/richbohn/> requires the ionCube PHP Loader to be installed by> the site administrator

I have methodically worked through your wikis on Advanced PHP configuration (PHP5), .htaccess, and php.ini. I think That I am close
but my two WP sites are still down:

My .htaccess file is: /home/richbohn/
ForceType php5-cgi> Options +ExecCGI
AddHandler php5-fastcgi .php
Action php5-fastcgi /php5/php5-wrapper.fcgi
<FilesMatch “^php5?.(ini|cgi)$”>> Order Deny,Allow> Deny from All> Allow from env=REDIRECT_STATUS>

If there is a problem here, I do not see it. This is directly from the DreamHost advanced php wiki. However, I do not see where the correct php.ini is called.

My php.ini is located at: /home/richbohn/

(is this the correct location?) (The cgi directory was created when the
software vendor installed the infusionwp program)

The first line of the php.ini is:> > zend_extension => /home/richbohn/>

This does not match the error message above ( So, I do not think the correct php.ini is loading and I am not sure why. I am still getting the 500 memory errors and I have bumped things up quite a bit.

Can anyone suggest changes that I should make to the .htaccess file or php.ini? I suspect That I am very close to getting things running again and would appreciate any advice!

This is now a serious situation. I really need to get these two WP blogs back online.

If there is a guru-for-hire lurking out there, just send me an email and let’s come to terms.


Rich Bohn


check your apache error logs. it will contain more specific information on your 500 errors

also, those ‘>’ in your htaccess file are not in the real file are they? they shouldn’t be there.