Internal error after running Ioncube script

apps

#1

I am getting an internal server error after running a script to install the ioncube loaders.

I got the script from here:

http://sxi.sabrextreme.com/forum/

This is my site:

http://nzproperty.org

How can I start to troubleshoot this problem?


#2

Have you looked at your Apache error log to see what the error actually is?

The error log is under your shell user directory:

/home/username/logs/

where ‘username’ is the shell user (Unix login ID).


#3

Here are some of the errors:

[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] dispatch.cgi: line 3: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: Permission denied
[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] dispatch.cgi: line 3: exec: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: cannot execute: Success
[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] Premature end of script headers: dispatch.cgi
[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] dispatch.cgi: line 3: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: Permission denied
[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] dispatch.cgi: line 3: exec: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: cannot execute: Success
[Mon Jul 13 01:13:26 2009] [error] [client 64.34.85.75] Premature end of script headers: dispatch.cgi
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] dispatch.cgi: line 3: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: Permission denied
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] dispatch.cgi: line 3: exec: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: cannot execute: Success
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] Premature end of script headers: dispatch.cgi
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] dispatch.cgi: line 3: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: Permission denied
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] dispatch.cgi: line 3: exec: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: cannot execute: Success
[Mon Jul 13 01:16:57 2009] [error] [client 119.63.193.107] Premature end of script headers: dispatch.cgi
[Mon Jul 13 01:36:58 2009] [error] [client 114.80.93.71] dispatch.cgi: line 3: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: Permission denied, referer: http://nzproperty.org/
[Mon Jul 13 01:36:58 2009] [error] [client 114.80.93.71] dispatch.cgi: line 3: exec: /home/.neiman/nzproperty/nzproperty.org/cgi-bin/php.cgi: cannot execute: Success, referer: http://nzproperty.org/
[Mon Jul 13 01:36:58 2009] [error] [client 114.80.93.71] Premature end of script headers: dispatch.cgi, referer: http://nzproperty.org/
[Mon Jul 13 01:36:58 2009] [error] [client 114.80.93.71] dispatch.cgi: line 3:


#4

Anyone?

Maybe the answer is to just try and move the site to another hosting company…