Interesting PHP Issue

software development

#1

ok, i finally expanded my file uploads size using this tutorial:
http://wiki.dreamhost.com/index.php/PHP.ini

but now, ever since i did that, when i try to use:
$_SERVER[‘SCRIPT_FILENAME’]

instead of displaying “filename.php” like it used to, it now displays “php.cgi”

also here is the exact text in my .htaccess:

Options ExecCGI
AddHandler php-cgi .php
Action php-cgi /cgi-bin/php.cgi

Help?

www.csscobalt.com | Free Image/File Hosting!


#2

Probably because it’s thinking it needs to spit out the file name specified in the Action? Try changing php.cgi to another file name.


#3

Try

AddHandler phpFour .php
Action phpFour /cgi-bin/php.cgi

or

AddHandler phpFive .php
Action phpFive /cgi-bin/php.cgi

Silk

My website