Installing Trac

apps

#1

I’m trying to move a Trac environment from my old server and am getting troubles. The svn repo moved cleanly.
I’ve installed Python 2.3.5, Clearsilver 0.9.14, SQLite 3.3.4 (thread safe), PySQLite 2.0.7, SWIG 1.3.29 and Subversion 1.3.0 (all using the instructions from the wiki).
Trying to create a new clean environment fails with segmentation fault when trying to index the repository.

Anyone knows what may the problem be?

Thanks,
Ofri


#2

Having the same problem…

As far as I know the error is related to buggy svn binding aka, SWIG.

I’ll post again if I come up with a solution.


#3

I know exactly what you’re problem is. (I had the same issue, and used strace to find the problem.)

Here’s the solution:
After you’re done installing subversion, you need to make the libraries available from the location referenced. (libsvn and svn)
In my installation, these are the exact commands that I executed to fix this:
cd ~/packages/lib/python2.3/site-packages
ln -s ~/packages/lib/svn-python/libsvn
ln -s ~/packages/lib/svn-python/svn

This is taken from my guide at http://natmaster.com/articles/installing_trac.php so you can probably figure out what’s best for your setup based on the information there.

Ask me if you need any more help!