Installing RSSFWD

software development

#1

http://www.rssfwd.com/rssfwd/developers < How to install RssFwd

[quote] [server]$ rake migrate
/usr/bin/rake:17:Warning: require_gem is obsolete. Use gem instead.
(in /home/.pati/usr/rssfwd.site.net)[/quote]

what do ‘require_gem is obsolete? use gem instead’ mean??

learning as i go, thanks in advance!


#2
  1. on Run your own RssFwd server says:
    6.1. Create a database < or 3? (production,development,test)
    6.2. Configure config/database.yml (configured wtih production,development,test db’s)
    6.3. Let Rails migrations do the rest, execute: rake migrate
    (should this be 5.1,5.2,5.3 ?)

‘deprecated’? ‘replacement version’? starting the server:

[quote][server]$ ./script/server
=> Booting WEBrick…
=> Rails application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2007-02-28 01:18:09] INFO WEBrick 1.3.1
[2007-02-28 01:18:09] INFO ruby 1.8.5 (2006-08-25) [i386-linux]
[2007-02-28 01:18:09] INFO WEBrick::HTTPServer#start: pid=4874 port=3000[/quote]
if i go to http://rssfwd.site.net/ i see the root folder and the files (need to set to /usr/rssfwd.site.net/pulblic/)
ok, now when i go to http://rssfwd.site.net/ it says welcome, create databases and edit config/database.yml
when i go to http://rssfwd.site.net:3000/ it says the same. (ie - see 6.1)

http://rssfwd.site.net/rssfwd/ shows me the application but when i run it i get the error: ‘We’re sorry, but something went wrong. We’ve been notified about this issue and we’ll take a look at it shortly.’ i have not been notified at admin_email in rssfwd.yml

what’s preventing rssfwd from working? (other than me :p) i know the answer is on one of the pages below. i have been over them but i’m missing it. help!

http://blog.dreamhosters.com/kbase/index.cgi?area=3109
http://wiki.dreamhost.com/index.php/Ruby
http://wiki.dreamhost.com/index.php/Rails

Thanks! (app is @ http://rssfwd.polipedia.net/rssfwd )