Installing RMagick


#1

Hello,

I am working on a module for a ruby on rails application (on my ps account) which requires RMagick. I am trying to follow the directions on the wiki for loading RMagick ~ http://wiki.dreamhost.com/RMagick ~, but am obviously making a mistake somewhere. It would be helpful if someone knowledgeable of using shell could help me work out the kinks…

So I did the first part with no problems:

[quote]Install your own version of ImageMagick, following the configuration instructions as given at Compiling ImageMagick

* This may take a few attempts, as it is very CPU intensive when running the tests, and this apparently causes DreamHost to periodically kill the build.
* If you're only planning on using ImageMagick for RMagick, you can save a little time and disk space by using the --without-perl and --without-magick-plus-plus options when configuring the ImageMagick build. This disables PerlMagick and Magick++.
* Be sure to include these configuration options: --with-gslib --with-gs-font-dir=/usr/share/fonts/type1/gsfonts/ [/quote]

The second part was just as easy. If I understand correctly the 'cd ~ ’ command takes me down to the root of my user’s shell access (from the ImageMagick-6.7.9-0 folder).

[quote] * After installing ImageMagick cd ~ and set the paths for the binary and libraries. With these settings you’ll be able to use RMagick under FastCGI without needing to work around the LD_LIBRARY_PATH environment variable:

$ export PATH=$HOME/local/bin:$PATH
$ export LDFLAGS=-L/$HOME/local/lib
$ export CPPFLAGS=-I/$HOME/local/include
$ export LD_RUN_PATH=$HOME/local/lib
[/quote]

Then I get this command

[quote]Create your own gems repository
mkdir ~/gems[/quote]

Where does ‘~/’ place the gems directory in relation to the my root usr? (That becomes an issue later…)

Setting the environment variable is not a problem, but I’m not sure I quite understand the instruction to ‘configure ~/.gemrc.’ I used ‘emacs ~/.gemrc’ to create and save the YML configuration suggested below. I don’t know if that’s right.

[quote] * Set your gems environment
o Set environment variable
export GEM_PATH=$HOME/gems:/usr/local/lib/ruby/gems/1.8; export GEM_HOME=$HOME/gems
o Configure ~/.gemrc (a YAML format file):

gemhome: /home//gems
gempath:

  • /home//gems
  • /usr/local/lib/ruby/gems/1.8
    [/quote]

Then there is this. The echo $PATH suggestion is straight forward, but I don’t know what it mean to ‘Make sure your .bash_profile is sourced.’

The next command says to ‘cd ~/src’ but that returns an error (’-bash: cd: /home//src: No such file or directory’) because I’m already at the root of my shell access.

I’ll stop right there. If I can work through the issues mentioned above… I think I can finish out the installation. Anyone willing to provide some advice?

Thanks.