Installing phpmyadmin

software development

#1

I just set up a mysql database yesterday and I have installed phpmyadmin but I am getting errors when I try to access phpmyadmin. This is the error I am getting:

Warning: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111) in /home/.alise/dreding/powerleveling.com/phpAdmin/lib.inc.php on line 309

Warning: MySQL Connection Failed: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111) in /home/.alise/dreding/powerleveling.com/phpAdmin/lib.inc.php on line 309
Error
MySQL said: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)

In the Dreamhost control panel I set up a mysql user setting a username and password, I then plugged that username and password into the config file of phpmyadmin.

I then set up a mysql hostname in the control panel called “localhost” and used that as the hostname in the config file of phpmyadmin.

Is there something else I need to do or have I set up the phpmyadmin config file wrong??


#2

This is just a guess, but if the MySQL host you set up is called “localhost”, then the actual MySQL server is “localhost.yourdomain.com” (or whatever the domain you attach it to is). If you just use “localhost” in your phpmyadmin config, I don’t think it’ll work–you have to use the full domain.


#3

Thanks, I’ll give it a try.


#4

No joy, I am still getting the same errors.


#5

actually, your problems may be solved now… we just put out (as a beta) our own centralized phpmyadmin install for all our customer’s mysql dbs! Just go to your mysql hostname on the web and then type in your database username and password in the password box that pops up. so go to something like http://mysql.domain.com/ or whatever you set the mysql hostname to be!

josh!