Installing Perl Modules


#1

Hi guys,

So apparently for this CGI script I’m using to work, I’ve been told that I require the perl mod ‘Image::PNG’

Are there any tricks or methods to install this into my server without having to learn unix shell, such as just through FTP?

I’m afraid that most of the information provided on the wiki regarding perl mod installation via shell access is pretty much beyond me.


#2

the instructions on the wiki are pretty much the only way to do it.

i guess you could find the module, and pop it in your include path, but you’ll need to set a local one anyway since you’re on shared hosting…

have a go at following the wiki


#3

Bummer. I wish there were a more comprehensible guide for people who have never used shell access before.


#4

what can’t you figure out from the wiki? it looks pretty basic to me. tells you exactly what to type, etc. have you tried google? i see 5-6 tutorials just on the first page www.google.com/search?q=install+perl+module+dreamhost


#5

I’ve tried a few of those tutorials that didn’t require shell access already.
The wiki does seem pretty basic, but there’s a few parts that trip me up on http://wiki.dreamhost.com/CPAN

I’m afraid I get lost from the second step in:

How/where do I access ~/.profile?

Sorry, I’m entirely new to this.


#6

type ‘nano ~/.profile’ from your shell account. Copy that stuff into the screen. ctrl-x to quit (save on the way). done.

there’s nothing inherently difficult about using a shell. it’s just like dos.


#7

Thanks, still having difficulties, however…

When installing the module via cpan, it comes up with:

/usr/include/libpng12/pngconf.h:326: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before â.â token /usr/include/libpng12/pngconf.h:327: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âincludeâ make: *** [Libpng.o] Error 1 BKB/Image-PNG-0.08.tar.gz make -- NOT OK Running make test Can't test without successful make Running make install Make had returned bad status, install seems impossible Failed during this command: BKB/Image-PNG-0.08.tar.gz : make NO

The wiki entry is still a tiny bit vague on exactly which parameters need to be entered, although I’m fairly sure I input them all correctly. Any ideas?