Installing PECL packages in custom PHP5

software development

#1

I have a custom install of PHP5 in ~/php5, with PEAR working just fine. However, when I try to install a PECL package, I get the following problems:

$ ~/php5/php/bin/pear install pecl/perl

/home/bldesign/php5/php/bin/phpize: /usr/local/tmp/tmp76fxxX/perl-1.0.0/build/shtool: /bin/sh: bad interpreter: Permission denied
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

I’ve tried installing autoconf and adding it to the PATH, and setting PHP_AUTOCONF to point to autoconf. After doing that, autoconf will run from any directory, but I still get the error that it can’t find autoconf when I run phpize.

Also, I changed my pear config to put pear installer cache files in ~/php5/tmp instead of /usr/local/tmp, yet I still get the bad interpreter error.

Anyone dealt with this before?


#2

Did you see this forum thread? Just a thought. :wink:

–rlparker


#3

Yes, but I don’t see any other tmp directories in pear config-show besides the one I already changed. Which didn’t change a thing, unfortunately.