Installing MySQL on SSD VPS fails with bad init scripts

vps

#1

I’m trying to install mysql on one of my SSD VPS’s and running into a problem that appears to be an issue for Ubuntu 12.02 MySQL in general.

As it says to do on help.ubuntu.com I installed it using apt-get install mysql-server

During the printout of the installation, a message gets printed saying “Unknown job: mysql”

Entering the command “sudo service mysql start” gives me that message as well. Running “update-rc.d mysql enable” makes it print a message saying that /etc/init.d/mysql is “missing LSB information” and I should look ok wiki.debian.org to see how to make an LSB script. Further that “System start/stop links for /etc/init.d/mysql do not exist”

Why am I doing this? I do have a MYSQLPS and several years ago when I set that up it did improve performance. However, I have needed to customize the settings on that MySQL server and sometimes the Dreamhost service person suggests that I instead install my own MySQL on my server.

Basically - the performance with the MYSQLPS is not good. Further, because this is an SSD VPS a locally installed database should fly like the wind.

FWIW I’ve been yahoogling for info on the problem above and am finding some postings and discussion of that behavior. But nothing has come up saying how to fix the problem.


#2

Well, seeing that the VPS’s of dreamhost has been modified to work with their SQL & control panel, it’ll be troublesome. Have you tried this?

http://howtogetitworking.com/2011/06/28/installing-mysqld-dreamhost-vps/

Remember that the sources list may need to be altered as well. This one is for debian, but might be working just as fine if you use the correct sources list for ubuntu.