Installing my own version of FFmpeg


#1

I followed the instructions on the Wiki to the letter:

http://wiki.dreamhost.com/FFmpeg

I can create and chmod the 3 folders no problem. I used both the svn checkout from the wiki, and from the official ffmpeg site, but when I get to the configure part, I type it exactly as it appears:

./configure --prefix=$HOME --enable-cross-compile --enable-sharedAnd I get this message:

[code]Must specify target arch and OS when cross-compiling

If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file “config.err” produced by configure as this will help
solving the problem.[/code]I didn’t think this was an error, so I continued to the next step, make. When I type make I get this error:

Makefile:1: config.mak: No such file or directory libavutil/Makefile:1: libavutil/../config.mak: No such file or directory libavutil/../subdir.mak:96: warning: overriding commands for target `libavutil/' libavutil/../subdir.mak:26: warning: ignoring old commands for target `libavutil/' libavutil/../subdir.mak:96: warning: overriding commands for target `libavutil/' libavutil/../subdir.mak:96: warning: ignoring old commands for target `libavutil/' make: *** No rule to make target `libavutil/../config.mak'. Stop.Obviously an error. I decided to try continuing and typed make install and got the same thing:

Makefile:1: config.mak: No such file or directory libavutil/Makefile:1: libavutil/../config.mak: No such file or directory libavutil/../subdir.mak:96: warning: overriding commands for target `libavutil/' libavutil/../subdir.mak:26: warning: ignoring old commands for target `libavutil/' libavutil/../subdir.mak:96: warning: overriding commands for target `libavutil/' libavutil/../subdir.mak:96: warning: ignoring old commands for target `libavutil/' make: *** No rule to make target `libavutil/../config.mak'. Stop.Nothing appears in the bin, lib, or tmp directories. Something is obviously wrong here, but I don’t know enough about this sorta thing to fix it. I really want a newer version of ffmpeg than Dreamhost offers, I especially want the qt-faststart module. Can someone PLEASE help me figure this out, I hate it when instructions like this don’t work!


#2

Try building MPlayer-1.0rc2 first.

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

No need. mplayer and ffmpeg are completely unrelated.

OP: Drop the --enable-cross-compile and try again. Also, there should be a somewhat more recent version of ffmpeg (September '09) in /dh/bin/ffmpeg.


#4

The main reason I wanted to do this was because I need tools/qt-faststart, so I can convert my mp4 videos to be mobile-compatible. I think I managed to get this to work, I used the make tools/qt-faststart command and it seemed to compile, so I moved the compiled qt-faststart file into my /bin directory and it seems to work, I ran a file through it and it works on my phone just fine.