Installing Movable Type


#1

Hi. I need to install Movable Type on one of my Dreamhost domains. I’ve previously installed MT 3.2 without any problem. The new version is 3.34 and it apparently has some different host requirements.

Does anyone know if Dreamhost meets the new 3.34 host requirements, as copied below from the MT documentation?

Apache 1.3x, Apache 2.x

Perl Version:
will run on 5.6.1 or higher
officially supported on 5.8.1

Thank you.


#2

From wiki

Dreamhost uses Perl version 5.8.4

From php_info()

SERVER_SOFTWARE Apache/2.0.54 (Unix)

so should run fine

Get [color=#00CC00]FULL DISCOUNT[/color] off any hosting plan using [color=#CC0000]DISCOMBO97[/color].


#3

Thanks for the reply, monkeyboy7706.

Well, I’ve got MT 3.34 installed following these instructions for 3.2 at:
http://wiki.dreamhost.com/index.php/Movable_Type/MT3.2

The basic installation went ok, and I have access to the MT interface. But after making an entry, rebuilding MT, and trying to view the site (blog), all I get is a directory listing. When I look at the folder using FTP or Dreamweaver, I can see that it is empty.

MT also seems to have created the tables in the specified mysql db.

I believe the problem has something to do with the how the Publishing Paths are set up under MT’s Settings Menu. I’m hoping someone can tell me what I’m doing wrong.

There are two settings, one for the Site URL, and one for the Site Root. I’ve previously set up MT 3.2 for another domain and it is working fine.

For the Site URL, I have http://www.domain.com/blog.
This is the same path structure as in the blog that works correctly on the other domain.

For the Site Root, I’ve tried various things. Some of them cause MT to throw an error when rebuilding, others do not, but none of them actually result in the correct blog folders and files being created.

In the blog that is working correctly, the Site Root has this structure:
/home/.laughton/DreamhostAccountName/domain.com/blog.

When I use that for the Site Root in the new blog, MT gives this error upon rebuilding:

Error making path ‘/home/.laughton/DreamhostAccountName/domain.com/blog’: mkdir /home/.laughton/DreamhostAccountName/domain.com/blog: Permission denied at lib/MT/FileMgr/Local.pm line 107

Both blogs are on the same DH account, so the name there should be the same. My understanding is that .laughton is a DH server name. When I change it to .saltine, which is what the DH control panel shows is the ‘machine’ for the current user, I get the same error.

If I use the Site URL path for the Site Root, MT doesn’t give a rebuild error, but the folders/pages are still not created.

This must be something fairly simple, but I have no idea what.

Any ideas?

Thank you!


#4

well, I think the problem is that you have both blogs publishing to the same place. It is very early in the morning for me so maybe I’m missing something. I’d decided on a different folder for the new install to publish to and create that folder, then update MT to use it.

.laughton does refer to the actual server you’re on. IIRC the machine listed in the panel is like the main machine of a small cluster - of which .laughton is the actual one you’re on. Anyways, it’s best to remove that entirely, just have
/home/username/domain.com/blog.

Hope this helps.

–Matttail
art.googlies.net - personal website