Installing MOVABLE TYPE on DH



I’m having troubles figuring out how to install MT 3.2 on my dreamhost account.

I have a host and a DB ready for that, but however when it gets to configuring the software… that’s another story.

If anyone can help me out with that it would be very appreciated!

My msn is if anyone wana help me out with this live, otherwise you can post links to good references here.


  • Jones


this may be of some help:

Umm, if you could post a bit more speciifcally what issues you’re running into I should be able to help.



It’s mostly about the mt.cfg configuration, things like locating perl and saying which bd to use and everything?



If you have questions that aren’t answered in the Movable Type manual or knowledge base, you might want to try their support forums. You’re bound to get better support there than you will here.

If you want useful replies, ask smart questions.


well, I’ll post the basics of one of my mt.cfg file below. The path to perl is correct as default so you don’t need to edit that. And the other stuff is pretty self explnitory if you want to change things around.

Movable Type configuration file [mt.cfg]

This configuration file holds system-wide configuration

settings that apply to all of the blogs in your Movable

Type installation.

Movable Type uses the CGIPath setting to construct links back to

CGI scripts; for example, the MT tag <$MTCGIPath$> is substituted

with the value of the CGIPath setting. You will need to change this

value when you first install MT; instructions for doing so are in

the Installation Instructions, in INSTALLING THE MOVABLE TYPE



The filesystem path to the ‘db’ directory, where your MT database

files are stored. You will probably need to change this when you

first install MT; instructions for doing so are in the Installation


Consider using the MySQL configuration, below.

DataSource ./db

The following options are commented out: to uncomment an

option, remove the ‘#’ at the beginning of the line.

First, however, make sure that you understand the purpose

of the configuration setting.

Configuration for MySQL databases. Add the name of your database

and the username that you have for logging in to that database

below. The password needs to go in the file mt-db-pass.cgi.

ObjectDriver DBI::mysql
Database database_name
DBUser usEr

ThrottleSeconds is the minimum number of seconds between comments

from a single IP address. Setting this to 0 will turn off the

throttling feature, which may make you vulnerable to

comment-flooding. The default is 20.

ThrottleSeconds 20

MT needs to have an email address, from which it can send notification

emails. This defaults to your author address, but some spam filters

will reject emails that are From: and To: the same address. If you

have another address you can use it here.

EmailVerificationSecret secreteWord

----- Now there’s a bunch of lines that are all commented out untill this part-----

When creating files and directories, Movable Type uses umask settings to

control the permissions set on the files. The default settings for file

creation (HTMLUmask, DBUmask, and UploadUmask) are 0111; for directory

creation (DirUmask), the default is 0000. You should not change these

settings unless you are running MT under cgiwrap or suexec, or some other

scenario where the MT application runs as you; in addition, you should not

change these settings unless you know what they mean, and what they do.

DBUmask 0022
HTMLUmask 0022
UploadUmask 0022
DirUmask 0022

---- And everything else in the file is default. ----

Should be pretty simple. Just read the lines where they explain what each variable is, and how to set it. Any line that starts with a # will be ignored by the program, so to “uncomment” something you just remove the #.

Hope this is helpful.



I configured it with what the default install notice says, heres what I get at load:

Chargement des données initiales dans le système…

An error occurred while loading data:

Bad ObjectDriver config: Erreur de connexion: Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)


I found the bug, the loading executed itself well thanks.

If I have anymore concerns I’ll post here again.


Logged-on my webblog right now!


(I had forgot to remove the # in front of the DB Host, now it’s fixed) ;p