Installing Mambo, turn on Magic Quotes GPC?

apps

#1

Like a previous poster regarding problems with mambo, the preinstall check said I had to turn off Register Globals.
This problem was fixed when I enabled php5.
But now the Magic Quotes GPC seems to have been turned OFF.
Anyone know to fix this?
And how important is this to running mambo?
thanks!


#2

Magic quotes being disabled is normally a good thing, because it gives you control over whether or not quotes are escaped. If Mambo needs magic_quotes_gpc to be enabled, your best bet would be to install your own copy of PHP5, and then edit the php.ini file to suit your needs.

A more robust solution would be to contact the creators of Mambo and ask them to consider patching their application so that it doesn’t need magic quotes to be working. Good luck with that, though.


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#3

Magic Quotes GPC == the devil.

It’s getting completely removed in PHP6 (ie: not “disabled”). I’d highly recommend finding another method that doesn’t require Magic quotes.

Just noticed this. You hadn’t tried it, yet. :stuck_out_tongue:
Hum, my guess is that it’s not required. Not for certain, but I do know I installed Mambo on one of my sites to play with and I’m pretty sure I was using PHP5 with MQ off.