Installing awstats

apps

#1

Hello, I downloaded awstats (the latest stable version - v6.1), extracted the files and uploaded them to my webspace. I changed the permissions on the ‘tools’ folder to 755. I go to the configure.pl script in my browser but nothing seems to happen. After the paragraph on awstats itself, I just get this line: -----> Running OS detected: Linux, BSD or Unix, with the page status saying done.

Can anyone offer any advice on how to get awstats installed. I’ve asked support but they said they are unable to help install any 3rd party scripts.

This is my first account with dreamhost.

Thanks


#2

I don’t remember awstats being especially easy to set up. But I do remember that the configure script should be run from the command line, rather than from a web browser.

i.e.: perl awstats_configure.pl

That configure script asks stuff about the Apache configuration, but none of this applies, so you can skip it. Actually, you can probably skip that script entirely and just create the config file by hand.

Go to the awstats cgi-bin directory, and make a copy of awstats.model.conf. Call it awstats.yourdomain.conf.

There are a few settings in there you’ll have to change. I believe these are the important ones:

LogFile="/home/yourusername/logs/yourdomain.com/http/access.log.%YYYY-24-%MM-24-Ý-2
4"
(that points to the archived log file from the previous day)

SiteDomain=“yourdomain.com

HostAliases=“www.yourdomain.com

DirData="/home/yourusername/data/awstats" (you’ll have to create this directory.)

Then you’ll need to add something to cron to get it to update every day. Do the update it some time in the early morning, say after 2 or 3 AM. The awstats documentation has the details on how to do this.


#3

I ended up just editing the config file myself (changing the settings you mentioned). Had to tweak Logfile to be:

LogFile="/home/eastend/logs/my.com/http/access.log.%YYYY-24-%MM-24-% DD-24"

(take out the space between % DD)
Works great!


#4

I found the program easy to install but the configure didn’t work so I did it manuall. Your suggestions helped A LOT!!!

I found the second date format worked and the first one didn’t and yes you must remove the space.

It only seems to create a .txt file in my data directory. When I enter a command with -output awstats.myname.html it doesn’t do anything, not even give me an error. And I’ve never seen any .html file in the data directory. Any thoughts?