Installing AROUNDMe

apps

#1

Ok, this will be the second part of quest for the AROUNDMe’s working state. The first one may be found at http://discussion.dreamhost.com/showflat.pl?Cat=&Board=3rdparty&Number=63431&page=0&view=collapsed&sb=5&o=365&part=1#Post63502
The topic for that post is named differently since I thought that FTP server was the only problem. I’m so naive.
What I’m trying to do now is to install it under PHP 4, not PHP 5 like it was before. We’ll see what happens…


#2

Sorry for the delay: I haven’t even moved the files yet. I’ll test the script under PHP5 tonight.


#3

Bill,

Last night I installed AROUNDme version 0.7.1 on a Dreamhost account (under PHP5), and learned a few things that might be helpful:

  1. I strongly suggest use of the “manual installation” instructions. The “easy installer” is “not yet ready for primetime” (at least in the DH environment), and you will have to “tweak” a lot of things in order to get a successful install using it - I started on the process and gave up; it was a lot easier to just install it manually than it would be to mangle the installation files and proceed with a “one-off” install. If you ever needed to install it again/in another place, you would have to do it all over again. The “manual install” is a lot easier.

  2. I installed the program by using wget to grab the tarball, unpacked it on the server, and copied the appropriate directories into my web space using cp - others may prefer downloading to their computer, and FTP’ing the files, etc. Unpacking on the server will leave many file/directory permissions set inappropriately on DH. Generally, on Dreamhost, Directories should be set to 755 and files to 644 (or even more restrictive).

  3. The “new” version of AROUNDme is a “ground up” re-write, and does not yet have the functionality of the older version(s) - blog and event modules are not yet released. This is clearly “alpha” code, and is not ready for installation on production sites (in spite of what looks to be a typo in the README and comments). Frankly, I only recommend it’s installation in a “testing” or “development” mode which, according to the Barnraiser site, is it’s intended use at this stage.

  4. Having completed the install, and setup, I now see that yet a newer version (0.7.2) is released today - the beast is in heavy development, has a few things that are not yet working right, and has a ways to go before it’s ready for “real” deployment.

–rlparker


#4

Ok, I gotta admit: I’m a bit dummy in regards to the lingo, so when you say that you used wget to grab the tarball, would that mean that you used the wget command to unpack the .tar file?
Also, you’ve mentioned that this is clearly “alpha” code. What’s the difference between alpha and beta?
I’ll try the manual way, we’ll see how it goes.


#5

Wget can be used to download straight to the server.

Tar is used to unpack the tarball.

Alpha comes before beta, so it’s less developed, and more likely to break or not work right.


They hired more support help.
Tip me (and DreamHost gets 5%+$0.30) Cut the code: [color=#00CC00]9999=$99.99 Off[/color]


#6

Hi, Bill!

Actually, once you use wget to copy the tarball onto the server, you use the “tar” command to unpack the file. The general usage for a “tar.gz” file (which is what was distributed) is:

tar -xzvf fullfilename.tar.gz

This will unpack the files in the tarball into a directory structure. Understand that if this is confusing to you, you can still use the “manual installation” method to install the program while unpacking the files to your own computer and ftp’ing them to you space; you don’t have to use wget and tar to manually install.

As for “alpha” vs “beta” (and for that matter “release candidate”, etc) is somehat subjective, it has to do with the “generation” of the code, with alpha being “the first”. Generally “alpha” code is expected to contain many undiscovered/unresolved bugs, may lack full functionality, and is in the earliest generation of development. “Beta” is usually further along in the process and has most of its intended functionality (though some features may still be missing), has had many bugs "squashed (and possibly others introduced), and is still not ready for production use. The “Web 2.0” world has taken to releasing some stuff in “perpetual Beta” fashion - meaning that it "works’ be is being continually developed.

–rlparker


#7

Oh, that’s cool, thanks! Now, how do I use wget? I’m in the PuTTY, logged in, type wget…what?
I’ve put down wget http://savannah.gnu.org/download/aroundme/aroundme_0_7_2.tar.tgz.
Here’s what it gave me:

[i][tab]$ wget http://savannah.gnu.org/download/aroundme/aroundme_0_7_2.tar.tgz
–18:36:35-- http://savannah.gnu.org/download/aroundme/aroundme_0_7_2.tar.tgz
=> aroundme_0_7_2.tar.tgz' Resolving savannah.gnu.org... 199.232.41.3 Connecting to savannah.gnu.org[199.232.41.3]:80... connected. HTTP request sent, awaiting response... 302 Found Location: http://download.savannah.gnu.org/releases/aroundme/aroundme_0_7_2.tar.tgz [following] --18:36:37-- http://download.savannah.gnu.org/releases/aroundme/aroundme_0_7_2.tar.tgz =>aroundme_0_7_2.tar.tgz’
Resolving download.savannah.gnu.org… 199.232.41.75
Connecting to download.savannah.gnu.org[199.232.41.75]:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 584,538 [application/x-tar]

100%[===================================================================>] 584,538 82.95K/s ETA 00:00

18:36:38 (82.90 KB/s) - `aroundme_0_7_2.tar.tgz’ saved [584538/584538][/i]

Damn, it looks really cool, now what do I do? When I go to my FTP, I see this file, aroundme_0_7_2.tar.tgz, but how do I unpack it? Oh, wait, maybe I have to use the wftp?

Ok, never mind, I saw Parker’s post…using the tar command to unpack the file…The general usage for a “tar.gz” file (which is what was distributed) is
tar -xzvf fullfilename.tar.gz. Why does it say …tar.tgz?


#8

Bill,

That was just an example, in this case your file is a .tgz file (similar, but slightly different). To update the “general example” for your particular case, you can unpack the .tgz file with:

tar -xzvf aroundme_0_7_2.tar.tgz

With either the wget or tar commands, (as with most unix shell commands) you can get help by using:

commandname --help and/or
man commandname

so to learn about “tar”, just use:

tar --help and/or
man tar

–rlparker


#9

Alright…
Ok, I’ve unpacked the file, so…how do I actually install it? Oh, wait…there’s this INSTALL.TXT file that I forgot about…Lets see:

[/quote]

  1. Copy the files to a directory in your web server. CHMOD to 770 the assets, cache and log directories. When uploading the fonts directory please ensure that you transfer in binary mode. Done, except for the binary part…I’m not sure what wget did.

  2. Use the included install/aroundme.sql file to populate a database (you will need to manually create a new database first). Well…how do I use it?


#10

That’s not relevant using wget, only important if you moved the files to your server via ftp.

You didn’t mention it, so I’m just reminding you that you need to have the aroundme directory (and all it’s subdirectories) in a “web accessible” directory - if you have not done that you will not be able to get to the application with a browser. That would generally mean making a copying the aroundme directory into you “whateveryourdomainiscalled.tld” directory, or some other place where it can be reached from the web. :wink:

aroundme.sql is just a text file that contains a series of SQL queries - you “use” it by causing those commands to be executed by the MySQL server on the host where you have the database installed. The easiest way (I think) to do this is to use PhpMyAdmin (just browse to your mysql host), select the database you want to use (have already created or an existing database), and select “import”. You will be given a form to fill out - instructions for all that are available in the PhpMyAdmin help, and other easily located places on the web (google!).

–rlparker


#11

I’ve imported the aroundme.sql and here’s what it gave me:

[i]Error

SQL query:

Table structure for table am_announce_role

CREATE TABLE am_announce_role (
announce_id INT( 11 ) NOT NULL AUTO_INCREMENT ,
role_id INT( 3 ) NULL
) ENGINE = InnoDB DEFAULT CHARSET = utf8;

MySQL said: Documentation
#1075 - Incorrect table definition; there can be only one auto column and it must be defined as a key[/i]

By the way, I don’t know what to do with this…HELP!


#12

Ok, I took a look at http://www.spiration.co.uk/post/1296 and think that I have to add PRIMARY KEY (role_id) right after role_id INT( 3 ) NULL, so my table looks like this:

CREATE TABLE am_announce_role (
announce_id INT( 11 ) NOT NULL auto_increment,
role_id INT( 3 ) NULL,
PRIMARY KEY (role_id)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

I did that and…no. Same poop comes out. I’ll try something else…


#13

It looks like you are experiencing the “joy” of working with “alpha” code :wink: - that error did not appear when running the .sql file that was included with the 0.7.1 version I installed last night.

Such instabilities, and the evolving nature of an application that is this stage of development require you to be “really committed” to work through these kinds of things to “test” the code. Good Luck with it!

–rlparker


#14

Yup, sounds supportive…:slight_smile: I’ll probably re-install 0.7.1 then b/c I honestly am not a MySQL guru, nor a coder and have absolutely no clue on how to solve this problem.
One more thing: when you installed AM properly, how could you forward index.php so that user sees www.domain.com and not www.domain.com/aroundme?


#15

Hey, I was not meaning to sound “less than supportive”, but installing 0.7.1 last night with the sole purpose of confirming that it can be installed on DH in order to help you, and being willing to answer your questions on that process, is a very different thing than trying to help you install 0.7.2 (with whatever changes have been incorporated) tonight.

If installing 0.7.1 is something that interests you, I can tell you that (to the degree the program “works”) it is installable on Dreamhost. It is not, however, “production ready”. It will have bugs, is missing functionality, and may have security issues. To the degree that playing with it is a valuable learning experience, or to the degree that it is a great “proof of concept” excercise, that might be a worthwhile experience.

I was honestly trying to warn you that this is very likely to be problematic even if you know what you are doing ( with php, the shell, and MySQL) precisely because of the “developmental” nature of the code.

If you look back at your posting history, I think you will have to admit that I, and others here, have been very supportive of you, even to the extent of working step by step through processes with you. There comes a point where you have to take a degree of this learning on yourself.

If you are going to work with MySQL, PHP, and the shell, you are going to have to do some studying. While you certainly can come to the forum after each “step” of a process, solicit help on how to accomplish that step, then repeat the process with the next step, you might find that others are more willing to help if you identify which parts of a project/process you don’t understand and make every effort to get a handle on that before just asking “how do I do this”. :wink:

I too am interested in the AROUNDme project, and will likely re-visit the code when they get a little further along with the development. As it is, and without the availability of the Blog, Events, and other modules that are in the demo, the project lacks the kind of functionality I would want in order to try to diddle it into being “ready for production”. If I had the time to help with the development of the project, I’d jump in and help work through this stuff; unfortunately I don’t have the time to devote to that process at present.

I’ll continue to help you when and how I can (as I’m sure will others), but I can’t always devote huge amounts of time “stepping you through” each process. I’m genuinely sorry if you do not feel that is sufficiently “supportive”. :slight_smile:

–rlparker


#16

Gee, it’s alright, I was just kidding :slight_smile: Of course you guys are supportive without any exception. By the way, what I did now was that I left 0.7.2 and imported 0.7.1’s aroundme.sql, and it worked perfectly :slight_smile:

[b] * Browse am_announce

  • Browse am_bookmark
  • Browse am_comment
  • Browse am_contact
  • Browse am_file
  • Browse am_file_allocation
  • Browse am_mem_type_access
  • Browse am_participation
  • Browse am_rate
  • Browse am_relation
  • Browse am_role_permission
  • Browse am_statistic
  • Browse am_tag
  • Browse am_template
  • Browse am_user
  • Browse am_user_blocked
  • Browse am_user_identity
  • Browse am_user_identity_custom
  • Browse am_user_invite
  • Browse am_user_language
  • Browse am_user_location
  • Browse am_user_message
  • Browse am_user_preference
  • Browse am_user_session
  • Browse am_user_testimonial[/b]

Import has been successfully finished, 26 queries executed.


#17

Bill,
Given the warning from Barnraiser that the code was “alpha” and not ready for production, I chose to install it so that it worked from http:domain.tld/aroundme (so it would not show up whenever someone browsed to the domain on which I installed the test). If I had wanted it to run from http://domain.tld, there are at least two “easyish” approaches I could have taken to make this happen:

  1. After getting it to run correctly from http://domian.tld/aroundme, I could have used the Dreamhost Control Panel to make the /home/user/domain.tld/aroundme directory be the “base” web directory for domain.tld (using Control Panel–>Manage Domains–>Edit (next to domain.tld in the list),and modified any configuration urls (not paths) to match that setup.

  2. I could have moved the contents (all the directories and files) of the distribution “aroundme” directory into my user directory /home/user/domain.tld (making the “around me” index.php be what is served from http://domain.tld), and installed it from there. This would have required “different” entries in the config file for both paths and urls where indicated, but would have been no more difficult than making those entries reflect the “http://domain.tld/aroundme” paths/urls.

You might also consider using a variation of “method 2” and install the application in the “base” of a subdomain of domain.tld (aroundme.domain.tld, or something like that).

A third approach (that I don’t find particularly “easy”) would be to attack the existing installation with apache rewrite rules - but I tend to avoid that, as I sometimes find it difficult to get them to work the way I want. :wink:

–rlparker


#18

That’s encouraging, but a caution is in order:

While it is possible that there was just a typo in the 0.7.2 .sql file, it is also possible that there was a change in database structure between versions. You have to carefully compare the two .sql files, and understand what differences you find, to know whether or not this is true.

If there is a difference in the tables, or data characteristics, between the two, running the 0.7.2 code against the 0.7.1 database will very likely break the application. :wink:

–rlparker


#19

That’s understandable. Now, I said that it worked perfectly too fast: I went to domain.tld/aroundme/index.php, and I get this:

Fatal error: Call to a member function set() on a non-object in /home/.orwell/willdex/domain/aroundme/components/core/error.php on line 27

And, what is line 27?

$tpl->set(‘error_id’, $_REQUEST[‘error’]); Wtf? It’s probably some table that hasn’t been created. Great! Turns out that I, most likely, will have to install 071.


#20

That is probably best, for reasons I explained in my previous post. You error messge, however, is more likely to do with permissions. Remember my opening post in this thread cautioned that the tarball has permissions set that don’t take into account DH running PHP-CGI under suexec.

Make sure you set all directories to 755, and all files to 644, clear your cache (and possibly re-start your browser), and try again.

–rlparker