Install uploadprogress php extension


#1

I’m looking to implement some sort of php file caching to create a progress bar when uploading files.

I have a custom php install 5.2 and attempted to install uploadprogress, a php module.

the command i start with is

install appears to go okay until i get an error at the end:

Installing '/usr/local/php5/lib/php/extensions/no-debug-non-zts-20060613/uploadprogress.so' ERROR: failed to mkdir /usr/local/php5/lib/php/extensions/no-debug-non-zts-20060613

any ideas on how to fix this? I tried manually making that folder but don’t have permission to the root level of the server.


#2

So i’ve noticed this:

I can install extensions properly with pear. It’s only when I try to install any extension using the command “pear install pecl/xxxxx” . I’m not sure if/where there is a way to change the config options for pecl. I’ve tried verifying all the configs for pear using “pear config-show”.


#3

here is the copied shell output after running the “pear install pecl/uploadprgress” command.

http://pastie.org/1916835


#4

Did you ever get this installed & working? Because I can’t :frowning:


#5

I’d be interested in any solutions to this.

I have the same issue with PHP 7.0 as I try to install PECL APCu.

Build process completed successfully Installing '/usr/local/php70/lib/php/extensions/no-debug-non-zts-20151012/apcu.so' ERROR: failed to write /usr/local/php70/lib/php/extensions/no-debug-non-zts-20151012/apcu.so (copy(/usr/local/php70/lib/php/extensions/no-debug-non-zts-20151012/apcu.so): failed to open stream: Permission denied)

I looked at pear config-show and saw that that directory was also showing up as the PEAR extensions directory, so I used pear config-set ext_dir /home/$USR/pear/ext to set it to to my user directory ($USR = my user name).

But I run it, I still get the same error at the end with it trying to access the '/usr/local/php70/lib/php/extensions/no-debug-non-zts-20151012/ directory.

Any suggestions?[/code]