Install/Update Libs on VPS


#1

Hi i begginer in linux e have some problems to install or update some libs on debian repositories in My VPS i’m a root and after try this command

the shell via Putty give this erros:

WARNING: The following packages cannot be authenticated!
libc-bin tzdata libc6-i386 libc-dev-bin libc6-dev linux-libc-dev locales
gcc-4.6-base multiarch-support libgcc1 libc6 liblzma5 xz-utils dpkg libuuid1
libblkid1 libslang2 libtinfo5 util-linux bzip2 libbz2-1.0 libstdc++6
libgmp10 libgmpxx4ldbl libgomp1 libmpfr4 libquadmath0 libmpc2 m4 binutils
cpp-4.6 cpp gcc-4.6 gcc libstdc++6-4.6-dev g+±4.6 g++ build-essential
libbz2-dev libgmp-dev libgmp3-dev mysql-common libmysqlclient16 libmysql++3
libmysql+±dev
Authentication warning overridden.
Extracting templates from packages: 100%
Preconfiguring packages …
Can’t exec “/tmp/tzdata.config.317631”: Permission denied at /usr/share/perl/5.8/IPC/Open3.pm line 168.
open2: exec of /tmp/tzdata.config.317631 configure 2009g-0etch1.1 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
tzdata failed to preconfigure, with exit status 9
Can’t exec “/tmp/locales.config.317633”: Permission denied at /usr/share/perl/5.8/IPC/Open3.pm line 168.
open2: exec of /tmp/locales.config.317633 configure 2.3.6.ds1-13etch10 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
locales failed to preconfigure, with exit status 9
Can’t exec “/tmp/libc6.config.317635”: Permission denied at /usr/share/perl/5.8/IPC/Open3.pm line 168.
open2: exec of /tmp/libc6.config.317635 configure 2.3.6.ds1-13etch10 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
libc6 failed to preconfigure, with exit status 9
Can’t exec “/tmp/util-linux.config.317637”: Permission denied at /usr/share/perl/5.8/IPC/Open3.pm line 168.
open2: exec of /tmp/util-linux.config.317637 configure 2.12r-19etch1 failed at /usr/share/perl5/Debconf/ConfModule.pm line 59
util-linux failed to preconfigure, with exit status 9
dpkg: regarding …/libc-bin_2.13-21_amd64.deb containing libc-bin:
package uses Breaks; not supported in this dpkg
dpkg: error processing /var/cache/apt/archives/libc-bin_2.13-21_amd64.deb (–unpack):
unsupported dependency problem - not installing libc-bin
Errors were encountered while processing:
/var/cache/apt/archives/libc-bin_2.13-21_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

i see all permissions in chmod and all is 777 for this on directory /tmp, /perl, /perl5 and the errors continue

somebody help me pls =]

sorry my bad english, thx


#2

try “sudo apt-get install build-essential m4 zlib1g-dev libbz2-dev libmysql+±dev libgmp3-dev”

I doubt DH allows you to install your own libraries though :frowning:


#3

I try using ‘sudo’ before apt get and not work the errors continue

Any idea ?

Thx for help friend


#4

It appears that you may be on a server running an older release of the operating system. Please contact DreamHost Support and request an upgrade to a newer release.


#5

Hey Andrew, so we can install our own packages on VPS!?


#6

Yes. That’s one of the major reasons that we offer root access on VPSes.