Install Drupal (without one-click)

apps

#1

Hi,
I’ve tried to install Drupal 6.9 by:
uncompressing it in a subfolder
copying the settings.default.php to settings.php
put all files and folders to chmod 777
trying to run the installation script
it works until the database section, there I set up all the info (also mysql.mydomain.com as server) and once I click on save and continue drupal just reloads this page again.
no way to install it.

I’ve then tried to modify directly the settings.php file, modifying the database info and the base url.
thanks to this it created all the tables on the db.
However it just stops on the following step, on the website configuration, by showing nothing in the central drupal panel.

could anyone install drupal ?


#2

Have you created a database?
http://wiki.dreamhost.com/MySQL

-Scott


#3

Just installed 6.9 then as a test, everything went fine (fast too!).

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#4

You may have had the same problem I did. In the instructions it says to copy default.settings.php and name it settings.php. I thought that it meant to rename the file but that was incorrect. You have to have BOTH files (default.settings.php and settings.php) or your intall will just hang at the page where you enter in all the mysql info.

Store: http://www.marciesgifts.com
PM for custom CMS/Blog/forum install/host transfer $75.
[color=#CC0000]$25 Off[/color] with promo code SPRINKLES


#5

The following worked for me.

*create a database and be sure to write down the dbname, hostname, username and password.
*Unzip Drupal install files locally.
*Open /sites/default/default.settings.php
**Find $db_url and change the value from mysql://username:password@localhost/databasename to
mysql://user:pass@DBHOST.YOURDOMAIN.COM/databasename (localhost will not work)
**Save the file and make a copy of it, naming the copy settings.php in the same directory (so there’s 2 files now)
*Upload only the actual files and folders in Drupal, not the Drupal folder itself. (Make sure .htaccess is in the root, view hidden files in your ftp client)

  • chmod ONLY /sites/default to 777
    *Go to YOURDOMAIN.com or whatever subdomain you put it on, should work real nice :slight_smile:

mail[at]mahalie[dot]com