"Index of /" error


Hi there.

I curently having problems getting my website up on one of my domains hosted with DreamHost. The domain I am having problems with (www.msilsby.com) is currently showing a page displaying “index of /” and “Parent directory”. This domain is registered through an external domain registration company.

I am using a program called RapidWeaver to publish my websites (I use a mac), using the inbuilt ftp client. This client has successfully published both sites to the respective /duff-silsby.com and /msilsby.com folders, however I can only see the website which has been published to the www.duff-silsby.com domain. I have also checked to make sure that the website is okay, by exporting it to another machine, to which the website showed no errors.

I have also tried uploading my website through an ftp client (captain ftp), without any luck. The one wierd thing I have noticed when I log in through the ftp client, is that where there is only the “/duff-silsby.com” folder for that respective domain name, there is both a “/msilsby.com” and a “/www.msilsby.com” folder for that domain.

Could this be partly to blame, and if so, what should I do to fix it?

Thanks in advance,



this directory is empty. what folder you copying the files into?

Use the coupon code [color=#CC0000]FIVEZEROOFF[/color] when signing up to Dreamhost for an instant [color=#CC0000]$50 off[/color]!


When you get hosting at DreamHost, they provide you with one or more folders in which to put your websites. Typically, these folders are the domain names themselves (although the Control Panel now offers the chance to call them by another name).

Right now, the folder for your msilsby.com domain (which may also be called that) is completely empty, so your publishing tool was unsuccessful.

Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


The site path being published to is /msilsby.com. When I view the folder through ftp, it shows the folder containing all of the necessary files. I have even tried deleting all of these files, and uploading directly from the hardrive, but with no luck.

Is there a reason why there would be both a /www.msilsby.com and a /msilsby.com file?


No. That is very odd. When you log in with an FTP client, you should see a list a bit like this:

domainname2.com (and so on, if you have more than 1)


And that’s pretty much it. I’ve never seen domain name folders prefixed with www before, unless they have been named that way when the domain was setup in the Control Panel.

Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]



It gets wierder. I am having a look in the control panel at the moment, and am coming across some wierd stuff. Mainly, in the “remap sub-directories”, “bandwidth”, and “Install new website software”, where there are two ‘www.msilsby.com’ domains, yet everywhere else (such as email addresses, and everthing under the domains tab) there is only one.


I recommend you open a support ticket, because that mess might take a little bit of sorting out!

Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


Thanks guys,

You have been awesome. I may just do that!


Just check that your ftp program and software is not creating those folders.



yeah, the ftp may have created the www.domain.com directory.

You may have to set your ftp up to look something like this:

to make sure they end up in your actual domain folder. Try moving your files into the domain folder without the www. do they show up then?