Index.htm not showing


#1

When I go to my main site, www.homeshade.com, it says the page cannot be found, but if I go to www.homeshade.com/index.htm it comes up…

Also, if I go to www.homeshade.com/Index.htm (note the uppercase I) it comes up with the page cannot be displayed.

This used to work just fine, I could just go to the .com site and it’d come up with the index.* that I had there, but I just deleted the entire site yesterday to redo it and now I’m having this problem.

Any suggestions?


#2

No, I don’t have FP Ext. enabled…I actually tried with Index.htm as well. If you go to the page right now, http://www.homeshade.com you’ll get the error, but if you go to http://www.homeshade.com/index.htm it’ll come right up.

Strange…


#3

well I just created a index.php and put it on the site and now http://www.homeshade.com works. So I wonder why it’s only seeing the .php file automatically???


#4

I’ve looked for a .htaccess file, but don’t see it, even viewed hidden files, nothing. I actually did to a search before I posted here. :slight_smile:

I did have the Run PHP as CGI option checked, so I disabled that, let it take effect and removed the .php file so that only the index.htm file was present, still would not read it and now get a Forbidden error.

Oh well, as long as the .php file works I’m fine with that, heh. I’m tired of messing with this for now.

Thanks for the help!


#5

Filenames and URLs are case sensitive, so Index.htm is a different name than index.htm.

Normally on the DH servers, both index.html and index.htm will work as a default index, but it’s possible to override this with configurations, as with .htaccess files. It sounds like in your case it’s overridden somehow; if there isn’t an .htaccess file in that directory, maybe there’s one in a parent directory of it?

– Dan