Index file replacement


#1

Whenever I overwrite/replace the index file, it takes days (if at all) to actually replace the file. The file has been uploaded, it’s just that the change isn’t being reflected on the site itself. I’m not sure whether this is a problem with my ftp (currently using cuteftp), with dreamhost, or other. Help?


#2

Sounds like you’re loading your page from the browser cache, not the recently uploaded file on the server. Try CTRL-F5 on windows, for example, or possibly hold down SHIFT while clicking the reload icon. (Sorry, dunno about Macs.) Or, delete your browser cache entirely through whatever means your favorite browser offers.


#3

If it has been days, probably not the cache. What program are you using to upload…dreamweaver? What OS are you using? Mac, PC? 9, 10, etc.

It really depends, especially with dreamweaver…which I think you are using.

Give more info, unless you have figured it out. If so, let other folks know what you did.


#4

Dreamweaver’s built-in ftp can sometimes cause that problem; however, in this case caitlin is using Cuteftp, not Dreamweaver.

  • marsbar

#5

I don’t see how it can be an ftp problem; either the software has ftp’d, or it hasn’t. There’s no way that Dreamweaver can suddenly ftp a file days later.

It would be a good idea to get somone else, using different ISP / servers / computers / to view your site.

Seems to me there’s a cache involved somewhere … but I couldn’t say whether it’s yours, or someone else’s!


#6

[quote]If it has been days, probably not the cache.

[/quote]

I have seen people loading REALLY old pages from a couple of weeks ago. Problem: they set their browser option of “check for newer versions of stored pages” (under “Temporary Internet files\ Settings”) to “automatically” (which is strangely not good enough) or even “never”. ALWAYS make it “Every visit to the page”.


DreamRegistrar.com


#7

I apologise if I was not clear in my post: I was not saying that Dreamweaver would suddenly FTP a file days later; I was saying the program would sometimes give the false impression that it had successfully ftp’d a file when it had not.
Cheers,
marsbar


#8

Right - I agree, I use Dreamweaver, but quickly returned to WS_FTP, as it’s much more transparent.

But this problem must be a cache problem.