Increase PHP Post Max Size through phprc


#1

It was recommended that I increase both my PHP Memory Limit and PHP Post Max Size. I was able to increase the memory limit just by upgrading from PHP 5.3 to 5.4. However, I still need to increase the memory limit, and I am trying to follow the Wiki instructions (http://wiki.dreamhost.com/PHP.ini#PHP_5.3_.2F_5.4).

I go to AjaXplorer (WebFTP.dreamhost.com), but I cannot seem to locate the home or my username directory in order to create the .php folder there. If I try adding a folder in the main directory (FTP Host) or one of the subdirectories (e.g., my domain name), I get error messages about forbidden or cannot access. What am I doing wrong?

Thanks!


#2

Try downloading and installing the FileZilla FTP client. It’s free and more reliable than using a web-based client to do that. You may have to under “Server” enable “force showing hidden files” as anything starting with . is considered “hidden”.


#3

Thanks, I was able to add a folder under the main directory using FileZilla. So, I now have a file listed as ftp://USERNAME@ftp.DOMAIN.com/.php/5.4/phprc (I’ve replaced username and domain with placeholders) I essentially copied and pasted the following (from the Wiki article) into notepad for the phprc file:

upload_max_filesize = 64M
post_max_size = 64M
max_execution_time = 500
max_input_time = 500

Then, I saved/uploaded it, and it appeared to successfully update it on the server. However, when I check the current PHP Post Max Size (in System Info for Headway in my WP dashboard), it still is showing only 7M.

Did I do something wrong? Or is there an extra step?

Thanks!
Tyler


#4

Nevermind – there was just a delay, and now it shows that it worked! Thanks.