Include_path not working?


#1

Hi

Been following the steps on the dreamhost wiki to try and include a new library in a sub domain. Now it seems to be reading the php.ini file as changing display_errors on and off does change eventually, however no matter what I seem to change for include_path just seems to get ignored completely.

Using set_include_path at the top of the test file works no problem at all.

Any ideas on what I’m doing wrong?

Cheers!


#2

nobody?

As an experiment I echo’d the get_include_path and it returned .:/usr/local/php5/lib/php but my php.ini file has the following include_path =
".:/usr/local/php5/lib/php:/usr/local/lib/php:/home/ijeffers/gdata.ijeffers.com/cgi-bin/library"


#3

Create a file:

info.php

<?php phpinfo(); ?>

And when you browse to it will show you all the settings and whether or not it is reading your php.ini file.

Customer since 2000 :cool: openvein.org


#4

It says it is on Loaded Configuration File, but still isn’t applying the include_path settings.

http://gdata.ijeffers.com/phpinfo.php
http://gdata.ijeffers.com/installationchecker1.php
http://gdata.ijeffers.com/cgi-bin/php.ini