Inbound email flagged as spam

Hello? Dreamhost…anyone going to answer?

Doubtful they’ll respond on the community forums. I’ll open a ticket as I’ve just this evening repointed MXes for quite a few domains to now route via Mailchannels ingress antispam. I’d rather avoid excessive false positives!

Saw this on the system status page yesterday:
“On Monday, October 12th and Tuesday, October 13th, between 4:00pm and 6:00pm PDT, we will be performing upgrades to our mail system. As a part of this scheduled maintenance, access to email via our webmail service and email applications may be intermittent or unavailable. We will keep this post up to date as the maintenance progresses.”

Wonder if this is related or another opportunity to underwhelm us?

I am seeing the same problems with my eMail forwarded from my gMail account. Super Frustrating!!

I let things sit for a bit, 50+ e-mails went into spam, more than half were legitimate e-mails, something like 80% from senders I regularly get e-mail from. sigh

I’m also having to go into my spam folder every day and move a lot of legitimate commercial emails back to the inbox. Checking the headers, I see

X-Spam-Reason: confirmed_spam
X-VR-STATUS: SPAM

in all of them.

I went to panel.dreamhost.com and tried to whitelist some of these senders. That also didn’t work very well. Sometimes I’d get a notice saying the domain had been added, but it wouldn’t actually show up in the list of allowed senders below. I often had to try several times before it would stick. And even then it’s not working. If I whitelist “@domain.com”, emails from “@notifications.domain.com” still end up in spam. Super frustrating, and a big waste of my time.

Same problem here, for a few weeks. I’ve previously had to harvest and whitelist basically every email correspondent to stop Dreamhost from flagging everything as spam, but I’ve found no workaround this time, Dreamhost needs to address it. This latest issue seems to have 2 problems:

  1. Legitimate notification emails with valid SPF and DKIM signatures from domains like linkedin.com, nextdoor.com, yelp.com etc are getting falsely flagged as spam, always with “X-Spam-Reason: confirmed_spam”

  2. The Allow/Block lists from the DH panel are not being applied. I’ve gone into messages and added every From, Return-Path, Reply-To and Message-ID FQDN as well as TLDs like @linkedin.com. Messages are still getting falsely classified as spam.

The false positives are annoying and they need to tune the filter, but issue #2 must be a straight bug. It’s annoying, and people are missing emails.

I’m convinced that they are aware that it’s their “new” middleman that’s screwing everything up here but they are either unwilling or incapable of fixing it.

Granting a middleman access to everyone’s raw emails in the first place leaves an incredibly sour taste in my mouth.

Wow, here’s, in part, the response I got from Dreamhost last week;

“I understand that our filtering service is causing issues for you
personally and for your businesses. If you are not satisfied with our
filtering service, you are more than welcome to turn it off…”

They don’t get it. Turn off a service we’re paying for? Come on Dreamhost, this is really not the customer service I’m use to from you.

Well now I’ve got inbound e-mail from Gmail, from a sender that’s been sending to me for years, and it’s been 2 hours and e-mail still hasn’t arrived… not even in the spam box?

You’ve cut off the part where it explains the “how” to turn it off.
Relinquish the rest of the chat and Cover Yourself in Glory! :crown:

Oh sure…here you go;

…you are more than welcome to turn it off by going
here:

https://panel.dreamhost.com/index.cgi?tree=mail.junk

Click on Edit Filter for your domain, click on the Edit Settings for
DOMAIN button under the “Domain-wide Settings,” and then click on Change
Filter Settings to toggle the filtering off. Please note, when it is
deactivated, any blocklists or allowlists will be removed permanently.
Also, it will take up to 4 hours for DNS propagation to propagate from
the filtering MX servers to ours. If you are using outside DNS, you will
need to manually update your MX servers to ours:

0 mx1.dreamhost.com
0 mx2.dreamhost.com

1 Like

You’re a legend! I was hesitant on changing the MX servers manually, but it appears they’re officially supporting it. I need to use this on at least two domains that have been misclassifying important mail as Spam.

This was the first day the spam filter was anywhere close to accurate… fingers crossed??