Impossible to delete directory


#1

Hi. I tried to installed a Gallery but I’va made an error. So I tried deleting the directory in which I’ve uploaded the files but I can’t delete it. I have the followeing message:
“You are not authorised to do this action, consult help for more informations”. I am the administrator of that domain but can’t delete something?


#2

Sounds like something is up with your FTP program. Look at settings for you FTP program and make sure that it is set to delete full (not empty) directories.

Or Try accessing via shell (SSH) and delete the directory that way. You can find instructions on accessing your files via SSH in the Kbase or in the Wiki.

-Matttail


#3

I had this problem when I tried Simple PHP Gallery (SPG) from Paul Griffin of Relatively Absolute. It was caching images, and I couldn’t delete the images or the folder that they were in. In the end, I got the DreamHost support dudes to fix it for me.


Simon Jessey
Keystone Websites | si-blog


#4

I would check the file/directory permissions and also see if there is an .htaccess file in there that you can’t see.


#5

This is most likely the case.

I had a folder which had a .htaccess file that was hiding from view. It wouldn’t allow me to delete the folder at all. Even recursive delete didn’t work for me.

This did work for me. In my FTP client (LeechFTP, great little thing) I added ‘-a’ to the LIST command (in the options menu). The next time I connected and entered into the directory, sure enough, there was the .htaccess file sitting there for me to blast away.

All’s well now! Hope this helps ya! :slight_smile:


#6

glad you got it fixed up!

-Matttail