Importing pages from Adobe Muse in WordPress leaves hyperlinks broken

wordpress
design
software development

#1

Hello, Dreamhost community.

I’m experiencing a hyperlink issue with my site, I’m really struggling to solve. Actually, I have no idea how to fix it.

So the issue could be on a few different platforms. I have used Adobe Muse to design the website, Dreamhost to host the site and WordPress for CMS, utilizing Muse-to-WordPress plug in. The issue I’m experiencing is when clicking on hyperlinks in the site it leads to a page not found URL. This happens with widgets I have manually entered the hyperlink into and also the default hyperlinking in Muse. The strange thing is, it works for a few hyperlinks in phone and tablet version of the site but not for others, while on the desktop version, no hyperlinks are working both in widgets and standard hyperlinks.

I have all the updated versions of all the programs and have assigned and converted the domain to VPS to improve performance. I’m working on secure https and have all HTTP protocols in check.

I have tried everything but have had no luck in solving this issue. If anyone has any advice it would be greatly appreciated.


#2

Unfortunately we can’t really guess what’s going on from what you say. Is the domain and website public? If it is, the easiest thing is to share the URL. Otherwise, edit your post sharing more details to be more clear. For example, say something like:

  • when I go th $URL I see $SOMETHING, I expect that click on $SOMETHING would result in $THIS but instead $THAT happens

Provide screenshots, exact error messages, log snippets or anything you’ve tried to debug the issue.


#3

Hello, Smaffulli.

I can defiantly share more details.

Here is the screen shot of the what I receive when clicking on any hyperlink on the site.

I will send another post with other images as I can only send one image a post.

Shaun.


#4

An example of the issue is shown in the following images when I select a hyperlink with in a widget. for example, a hover reveal widget, as seen in the image.

I’m diverted to this URL, which is noisin.com/modernthread.html the URL I manual entered in following the instructions from the Widget programmer.


#5

However, when I selected a standard hyperlink selected in Muse I experience the same issue.

Is this more descriptive or helpful ? or is there more information that will help.

Thanks so much for your response.

Shaun.


#6

Thanks for sharing more details. There are a couple of things that seem to be misconfigured. And I haven’t even gotten to the URLs missing…

First thing I notice, when I go to http://noisin.com/ my browser gets redirected to http://www.noisin.com/ but that end is misconfigured, so the connection drops. See below:

~$ curl http://noisin.com/
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="http://www.noisin.com/">here</a>.</p>
</body></html>

~$ curl http://www.noisin.com/ -v
*   Trying 208.97.170.181...
* Connected to www.noisin.com (208.97.170.181) port 80 (#0)
> GET / HTTP/1.1
> Host: www.noisin.com
> User-Agent: curl/7.47.0
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
< Date: Wed, 13 Sep 2017 05:37:12 GMT
< Server: Apache
< Location: http://noisin.com/
< Vary: Accept-Encoding
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8
< 
* Connection #0 to host www.noisin.com left intact

I also noticed that your SSL certificate is self-signed, which throws my browser into panic. Is this site hosted on DreamHost? If so, consider using the free Let’s Encrypt certificate which is universally accepted by browsers.

Now, going to your problem, it seems to me that this Muse-to-WordPress plugin you used has not worked as you expected. I am guessing that you created these nice html pages in Muse, but when the plugin imported them it lost the links or didn’t configure WordPress correctly or something…

I am not familiar with Muse nor with the plugin (I googled, and it looks like there is more than one Muse-to-WP plugin). Try to login into your wordpress admin site: do you see any content there? Like posts or pages? from the look of it, I can see only the “Hello World” post on https://noisin.com/2017/09/12/hello-world/ and nothing in the WordPress archives https://noisin.com/2017/09/. I would expect to see more pages, one for each of the URL you have on the front page. You need to do more work on your side to understand what that Muse-WP thing is supposed to do and why it’s failing.

Are you sure you need the whole WordPress for your site? Have you considered other options, like DreamHost Remixer http://remixer.com/?


#7

Hello Smaffulli.

With the first issue, would it be better to change the default URL to: Leave it alone: Both h ttp://www.noisin.com/ and h ttp://noisin.com/ will work? as shown in the image below.

Your question: I also noticed that your SSL certificate is self-signed, which throws my browser into panic. Is this site hosted on DreamHost? If so, consider using the free Let’s Encrypt certificate which is universally accepted by browsers.

Answer: Yes I host through Dreamhost and have now switched to Let’s Encrypt certificate, thank you for the advice.

Now to the linking issue, you would be correct with the pages in word press, there is only one visible in the WP dash board. I believe the Muse to Wordpress plug (the program I use, https://musetowordpress.com) uses its own programming to convert the muse HTML files to work on WP, so it would make sense if the programming for that plug in is not working with the linking in WP, as I think it works off a separate structure, but that is well and truly out of my understanding. I have reached out to their programming team and they are working on the issue now. Hopefully, they will be able to help solve it and I have identified the source of the issue.

Thank you so much for your help, I will wait and see if they are able to sort out the issue.

Shaun.


#8

the web server seems to respond correctly now, both the redirect issue and the SSL cert warning

Help me understand one thing: you created a handful of web pages in Adobe Muse, right? From what I read, Muse creates a static website. So if you simply upload these files into DreamHost webserver, you’ll be done. Why do you need to convert these pages to WordPress? Do you really need a dynamic site?


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.